summaryrefslogtreecommitdiff
path: root/opcodes/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'opcodes/configure.in')
-rw-r--r--opcodes/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/opcodes/configure.in b/opcodes/configure.in
index d98968841b5..587422b6d98 100644
--- a/opcodes/configure.in
+++ b/opcodes/configure.in
@@ -210,8 +210,10 @@ if test x${all_targets} = xfalse ; then
bfd_s390_arch) ta="$ta s390-dis.lo s390-opc.lo" ;;
bfd_sh_arch)
# We can't decide what we want just from the CPU family.
+ # We want SH5 support unless a specific version of sh is
+ # specified, as in sh3-elf, sh3b-linux-gnu, etc.
case " $target $canon_targets " in
- *" all "* | *" sh64-"* )
+ *" all "* | *" sh64-"* | *" sh-"* | *" shl-"*)
ta="$ta sh64-dis.lo sh64-opc.lo"
archdefs="$archdefs -DINCLUDE_SHMEDIA";;
esac;