summaryrefslogtreecommitdiff
path: root/opcodes/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'opcodes/configure.in')
-rw-r--r--opcodes/configure.in15
1 files changed, 9 insertions, 6 deletions
diff --git a/opcodes/configure.in b/opcodes/configure.in
index 89199243a2f..8c165fcf27e 100644
--- a/opcodes/configure.in
+++ b/opcodes/configure.in
@@ -1,10 +1,11 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-AC_PREREQ(2.13)
-AC_INIT(z8k-dis.c)
+AC_PREREQ(2.59)
+AC_INIT
+AC_CONFIG_SRCDIR([z8k-dis.c])
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AC_ISC_POSIX
# We currently only use the version number for the name of any shared
@@ -30,7 +31,7 @@ AM_PROG_LIBTOOL
AC_ARG_ENABLE(targets,
[ --enable-targets alternative target configurations],
[case "${enableval}" in
- yes | "") AC_ERROR(enable-targets option must specify target names or 'all')
+ yes | "") AC_MSG_ERROR([enable-targets option must specify target names or 'all'])
;;
no) enable_targets= ;;
*) enable_targets=$enableval ;;
@@ -177,6 +178,7 @@ if test x${all_targets} = xfalse ; then
bfd_avr_arch) ta="$ta avr-dis.lo" ;;
bfd_convex_arch) ;;
bfd_cris_arch) ta="$ta cris-dis.lo cris-opc.lo" ;;
+ bfd_crx_arch) ta="$ta crx-dis.lo crx-opc.lo" ;;
bfd_d10v_arch) ta="$ta d10v-dis.lo d10v-opc.lo" ;;
bfd_d30v_arch) ta="$ta d30v-dis.lo d30v-opc.lo" ;;
bfd_dlx_arch) ta="$ta dlx-dis.lo" ;;
@@ -284,5 +286,6 @@ fi
AC_SUBST(archdefs)
AC_SUBST(BFD_MACHINES)
-AC_OUTPUT(Makefile po/Makefile.in:po/Make-in,
-[sed -e '/POTFILES =/r po/POTFILES' po/Makefile.in > po/Makefile])
+AC_CONFIG_FILES([Makefile po/Makefile.in:po/Make-in])
+AC_CONFIG_COMMANDS([default],[[sed -e '/POTFILES =/r po/POTFILES' po/Makefile.in > po/Makefile]],[[]])
+AC_OUTPUT