summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am34
1 files changed, 1 insertions, 33 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1caa76e..337cbed 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -137,37 +137,5 @@ dtfetch_LDADD = ../src/libgdbm.la ../compat/libgdbm_compat.la
dtdel_LDADD = ../src/libgdbm.la ../compat/libgdbm_compat.la
d_creat_ce_LDADD = ../src/libgdbm.la ../compat/libgdbm_compat.la
-## -------------------- ##
-## DejaGNU Test suite. ##
-## -------------------- ##
-AUTOMAKE_OPTIONS = dejagnu
-DEJATOOL = gdbmtool
-RUNTESTFLAGS =
-CLEANFILES = *.log
-
-site.exp: Makefile
- @echo 'Making a new site.exp file...'
- @test ! -f site.bak || rm -f site.bak
- @echo '## these variables are automatically generated by make ##' > $@-t
- @echo '# Do not edit here. If you wish to override these values' >> $@-t
- @echo '# edit the last section' >> $@-t
- @echo 'set tool $(DEJATOOL)' >> $@-t
- @echo "set top_srcdir `cd $(top_srcdir); pwd`" >> $@-t
- @echo "set top_builddir `cd $(top_builddir); pwd`" >> $@-t
- @echo "set srcdir `cd $(srcdir); pwd`" >> $@-t
- @echo 'set objdir' `pwd` >> $@-t
- @echo 'set host_alias "$(host_alias)"' >> $@-t
- @echo 'set host_triplet $(host_triplet)' >> $@-t
- @echo 'set target_alias "$(target_alias)"' >> $@-t
- @echo 'set target_triplet $(target_triplet)' >> $@-t
- @echo 'set build_alias "$(build_alias)"' >> $@-t
- @echo 'set build_triplet $(build_triplet)' >> $@-t
- @echo '## All variables above are generated by configure. Do Not Edit ##' >> $@-t
- @test ! -f site.exp || sed '1,/^## All variables above are.*##/ d' site.exp >> $@-t
- @test ! -f site.exp || mv site.exp site.bak
- @mv $@-t site.exp
-
-EXTRA_DIST += \
- gdbmtool/base.exp\
- config/default.exp
+SUBDIRS = gdbmtool