summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorjacob berkman <jacob@ximian.com>2002-03-01 20:03:06 +0000
committerJacob Berkman <jberkman@src.gnome.org>2002-03-01 20:03:06 +0000
commit3842f2f11d885e1f4313064ca05a041de54570dc (patch)
treee2d425d81ed0fe4f86af48fed2f070beac3699d4 /Makefile.am
parent206119c9c1691d30189dde1bd4bc32fcab77d917 (diff)
downloadgdk-pixbuf-3842f2f11d885e1f4313064ca05a041de54570dc.tar.gz
replace uses of test -e with more portable test -f
2002-03-01 jacob berkman <jacob@ximian.com> * Makefile.am (install-data-hook): (dist-hook): replace uses of test -e with more portable test -f
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d126a78dd..6024710ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -145,8 +145,8 @@ DISTCLEANFILES = \
DEFAULT_GDKTARGET=x11
install-data-hook:
(cd $(DESTDIR)$(pkgconfigdir) && \
- test -e gdk-$(DEFAULT_GDKTARGET)-2.0.pc && \
- test -e gtk+-$(DEFAULT_GDKTARGET)-2.0.pc && \
+ test -f gdk-$(DEFAULT_GDKTARGET)-2.0.pc && \
+ test -f gtk+-$(DEFAULT_GDKTARGET)-2.0.pc && \
rm -f gdk-2.0.pc && cp -f gdk-$(DEFAULT_GDKTARGET)-2.0.pc gdk-2.0.pc && \
rm -f gtk+-2.0.pc && cp -f gtk+-$(DEFAULT_GDKTARGET)-2.0.pc gtk+-2.0.pc) || \
(cd $(DESTDIR)$(pkgconfigdir) && \
@@ -154,7 +154,7 @@ install-data-hook:
rm -f gtk+-2.0.pc && cp -f gtk+-$(GDKTARGET)-2.0.pc gtk+-2.0.pc)
dist-hook: gtk+.spec
- if test -e $(srcdir)/INSTALL.in && test -e $(srcdir)/README.in ; then \
+ if test -f $(srcdir)/INSTALL.in && test -f $(srcdir)/README.in ; then \
CONFIG_FILES="INSTALL:$(srcdir)/INSTALL.in README:$(srcdir)/README.in" \
CONFIG_HEADERS= \
$(SHELL) config.status \