summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>2001-03-07 14:49:21 +0000
committerTim Janik <timj@src.gnome.org>2001-03-07 14:49:21 +0000
commit35af5c4eba6c95646a5719bae796ece1dbf92275 (patch)
tree4a6bf8d5608b902657304b27796591f995ee82f6 /Makefile.am
parent026caeb02ab9c3c094b29383eb895f4fe5981bfd (diff)
downloadgdk-pixbuf-35af5c4eba6c95646a5719bae796ece1dbf92275.tar.gz
marshaller fixes.
Wed Mar 7 13:24:57 2001 Tim Janik <timj@gtk.org> * gtk/*.c: marshaller fixes. * gtk/gtkmarshal.list: extreme cleanup. * gtk/gtktreeview.c (gtk_tree_view_class_init): disable interface param spec for now. * gtk/gtktexttag.c (gtk_text_tag_set_property): use g_value_get_boxed() where appliable. * gtk/gtktypeutils.[hc]: updates to GLib API changes. special cased autogenerated boxed types from gtktypebuiltins_ids.c which are not reference counted: GtkSelectionData, GdkEvent, GdkColor, GtkTextIter, PangoTabArray, PangoFontDescription, GtkTreeIter and GtkTreePath. Thu Mar 1 03:58:56 2001 Tim Janik <timj@gtk.org> * gtk/gtktreeselection.h: * gtk/gtktreemodel.c: * gtk/gtktreedatalist.[hc]: fixed includes. no gobject/* file should be included directly, and gobject/gmarshal.h as well as gtk/gtkmarshal.h even can't be included directly. * Makefile.am: grr, install gtk-config-2.0. * gtk/testgtk.c: * gtk/simple.c: * gtk/gtkmenu.c: * gtk/gtkitemfactory.c: use g_object_connect() instead of passing "*signal*::*" args to gtk_widget_set(). * gtk/gtktypeutils.[hc]: got rid of GTK_TYPE_SIGNAL. * gtk/*.c: removed trailer arg from property setters and getters. macro fixups. Thu Mar 1 04:01:57 2001 Tim Janik <timj@gtk.org> * test-gdk-pixbuf.c: fixed includes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ee167e41..6ba3ec04a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,6 +149,10 @@ dist-hook: gtk+.spec
m4datadir = $(datadir)/aclocal
m4data_DATA = gtk-2.0.m4
+bin_SCRIPTS=gtk-config-2.0
+BUILT_SOURCES=gtk-config-2.0
+gtk-config-2.0: gtk-config-2.0.in
+
.PHONY: files release sanity snapshot
files: