summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathan Blandford <jrb@redhat.com>2001-11-19 21:18:22 +0000
committerJonathan Blandford <jrb@src.gnome.org>2001-11-19 21:18:22 +0000
commit630e935c21122d66751f1aa96ad3f98791759e90 (patch)
treec179c6c3bf63581ba7d9ea33dc50c62bb1468fbb /Makefile.am
parent224b2d682bb246ab74ce5437453dd44e44665ab4 (diff)
downloadgdk-pixbuf-630e935c21122d66751f1aa96ad3f98791759e90.tar.gz
Add a "resizable" property, to get rid of the
Mon Nov 19 15:30:51 2001 Jonathan Blandford <jrb@redhat.com> * gtk/gtktreeviewcolumn.c (gtk_tree_view_column_class_init): Add a "resizable" property, to get rid of the GTK_TREE_VIEW_COLUMN_RESIZABLE sizing flag. (gtk_tree_view_column_set_resizable): New function to set resizable. (gtk_tree_view_column_set_resizable): getter. * tests/testtreecolumns.c (add_clicked): modify for above change. * Makefile.am (install-data-hook): remove old .pc files before installing the new one. We used to symlink this, and it will break old installs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index fbf33ab52..564984596 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -143,17 +143,17 @@ DISTCLEANFILES = \
gtk+-$(GDKTARGET)-2.0-uninstalled.pc \
gdk-$(GDKTARGET)-2.0-uninstalled.pc
-## symlink gdk-2.0.pc and gtk+-2.0.pc to default target for the platform
+## copy the default target for this platform to gdk-2.0.pc and gtk+-2.0.pc
DEFAULT_GDKTARGET=x11
install-data-hook:
(cd $(DESTDIR)$(pkgconfigdir) && \
test -e gdk-$(DEFAULT_GDKTARGET)-2.0.pc && \
test -e gtk+-$(DEFAULT_GDKTARGET)-2.0.pc && \
- cp -f gdk-$(DEFAULT_GDKTARGET)-2.0.pc gdk-2.0.pc && \
- cp -f gtk+-$(DEFAULT_GDKTARGET)-2.0.pc gtk+-2.0.pc) || \
+ rm -f gdk-2.0.pc && cp -f gdk-$(DEFAULT_GDKTARGET)-2.0.pc gdk-2.0.pc && \
+ rm -f gtk+-2.0.pc && cp -f gtk+-$(DEFAULT_GDKTARGET)-2.0.pc gtk+-2.0.pc) || \
(cd $(DESTDIR)$(pkgconfigdir) && \
- cp -f gdk-$(GDKTARGET)-2.0.pc gdk-2.0.pc && \
- cp -f gtk+-$(GDKTARGET)-2.0.pc gtk+-2.0.pc)
+ rm -f gdk-2.0.pc && cp -f gdk-$(GDKTARGET)-2.0.pc gdk-2.0.pc && \
+ rm -f gtk+-2.0.pc && cp -f gtk+-$(GDKTARGET)-2.0.pc gtk+-2.0.pc)
dist-hook: gtk+.spec
if test -e $(srcdir)/INSTALL.in && test -e $(srcdir)/README.in ; then \