summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCST 1998 Shawn T. Amundson <amundson@gtk.org>1998-10-31 09:53:29 +0000
committerShawn Amundson <amundson@src.gnome.org>1998-10-31 09:53:29 +0000
commit4848d691e00a1cfe4dd6af55b6b74b7f208c605d (patch)
tree5604f0d591c55ddb4a2dfb47edc991a9e0bb46ad /Makefile.am
parent52f5eeab68fa6e1618932f6e5bd2d2da58af7f53 (diff)
downloadgdk-pixbuf-4848d691e00a1cfe4dd6af55b6b74b7f208c605d.tar.gz
Released GTK+ 1.1.3
Sat Oct 31 03:11:57 CST 1998 Shawn T. Amundson <amundson@gtk.org> * Released GTK+ 1.1.3 * INSTALL: * NEWS: * README: * gtk+.spec: * docs/gtk-config.1: updated for v1.1.3 * Makefile.am * sanity_check * docs/Makefile.am: Includes new 'make release' as well as 'make sanity'. Also handles html and text creation from html, and puts them into the distribution * docs/Makefile.sgml: removed, similar functionality is now in the Makefile.am file * docs/.cvsignore: ignore html and text directories * docs/glib.texi: removed (now in glib dist)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a023e5f7..9df27bcd0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,7 +84,7 @@ EXTRA_DIST = \
m4datadir = $(datadir)/aclocal
m4data_DATA = gtk.m4
-.PHONY: files populate checkin release
+.PHONY: files release sanity snapshot
files:
@files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
@@ -97,13 +97,14 @@ files:
done; \
done
-populate:
- @echo "populating project"
- @files=`$(MAKE) files | grep -v "make\[[1-9]\]"`; prcs populate -d gtk+.prj $$files
+release:
+ rm -rf .deps */.deps
+ cd docs && make distdocs
+ $(MAKE) distcheck
-checkin: populate
- @echo "checking in project"
- @prcs checkin
+sanity:
+ ./sanity_check $(VERSION)
-release:
+
+snapshot:
$(MAKE) dist distdir=$(PACKAGE)`date +"%y%m%d"`