summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-02 20:08:39 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-02 20:08:39 +0000
commitdfe5724765acc217ce43b4f96cc0d6dc2d73016c (patch)
treef4f403cf19baee12aa491a678383cae27ccade37 /Makefile.am
parentf832e3484d146343e6f6bf4b36c4f19746f521f2 (diff)
downloadgdk-pixbuf-dfe5724765acc217ce43b4f96cc0d6dc2d73016c.tar.gz
Default to --disable-gtk-doc (avoid Jade breakage) and --disable-static
Sat Mar 2 14:32:50 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Default to --disable-gtk-doc (avoid Jade breakage) and --disable-static (static linking causes problems with Xft changes.) * autogen.sh: Add --enable-gtk-doc by default. * Makefile.am: Add a 'mydistcheck' rule that passes --enable-gtk-doc to the configure since that is needed for 'make dist'. * docs/tutorial/Makefile.am (dist-hook): Don't distribute the PDF file. (Rule doesn't work on my system, plus it's big.) * gtk/Makefile.am: 'make dist' fixes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6024710ec..1abc1d946 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -185,3 +185,28 @@ sanity:
snapshot:
$(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
+
+
+# This is a version of the automake-1.4 distcheck rule modified
+# to pass --enable-gtk-doc to ./configure
+#
+mydistcheck: dist
+ -rm -rf $(distdir)
+ GZIP=$(GZIP_ENV) $(TAR) zxf $(distdir).tar.gz
+ mkdir $(distdir)/=build
+ mkdir $(distdir)/=inst
+ dc_install_base=`cd $(distdir)/=inst && pwd`; \
+ cd $(distdir)/=build \
+ && ../configure --srcdir=.. --prefix=$$dc_install_base --enable-gtk-doc \
+ && $(MAKE) $(AM_MAKEFLAGS) \
+ && $(MAKE) $(AM_MAKEFLAGS) dvi \
+ && $(MAKE) $(AM_MAKEFLAGS) check \
+ && $(MAKE) $(AM_MAKEFLAGS) install \
+ && $(MAKE) $(AM_MAKEFLAGS) installcheck \
+ && $(MAKE) $(AM_MAKEFLAGS) dist
+ -rm -rf $(distdir)
+ @banner="$(distdir).tar.gz is ready for distribution"; \
+ dashes=`echo "$$banner" | sed s/./=/g`; \
+ echo "$$dashes"; \
+ echo "$$banner"; \
+ echo "$$dashes"