summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2001-11-02 22:56:59 +0000
committerTor Lillqvist <tml@src.gnome.org>2001-11-02 22:56:59 +0000
commit1d15be159965ca4465127a3d1f7833a47080fa5a (patch)
tree900d5d8fad8cbfc5f3704a07cf32a8eacab8d312 /Makefile.am
parent050625298e15a57543ffefcce79ef2bf8edcc184 (diff)
downloadgdk-pixbuf-1d15be159965ca4465127a3d1f7833a47080fa5a.tar.gz
Use -no-undefined on Windows. Look for .dll or .so as appropriate as
2001-11-03 Tor Lillqvist <tml@iki.fi> * modules/input/Makefile.am: Use -no-undefined on Windows. Look for .dll or .so as appropriate as module suffix. * gtk-zip.sh.in: Use correct import library names. * gtk/gtk.def: Add a couple of missing entry points. (#63585) 2001-11-02 Tor Lillqvist <tml@iki.fi> * gtk/gtkrc.c (gtk_rc_make_default_dir): Fix typo: extraneous comma. Include gtkprivate.h for GTK_LIBDIR etc definitions on Windows. 2001-10-30 Tor Lillqvist <tml@iki.fi> * Makefile (install-data-hook): Use cp, not $(LN_S) on the .pc files. Configure on Win32 (running on Cygwin) thinks symlinks exist, but pkg-config is not necesarily a Cygwin program, and doesn't understand them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4dac8bafe..fbf33ab52 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,11 +149,11 @@ install-data-hook:
(cd $(DESTDIR)$(pkgconfigdir) && \
test -e gdk-$(DEFAULT_GDKTARGET)-2.0.pc && \
test -e gtk+-$(DEFAULT_GDKTARGET)-2.0.pc && \
- $(LN_S) -f gdk-$(DEFAULT_GDKTARGET)-2.0.pc gdk-2.0.pc && \
- $(LN_S) -f gtk+-$(DEFAULT_GDKTARGET)-2.0.pc gtk+-2.0.pc) || \
+ cp -f gdk-$(DEFAULT_GDKTARGET)-2.0.pc gdk-2.0.pc && \
+ cp -f gtk+-$(DEFAULT_GDKTARGET)-2.0.pc gtk+-2.0.pc) || \
(cd $(DESTDIR)$(pkgconfigdir) && \
- $(LN_S) -f gdk-$(GDKTARGET)-2.0.pc gdk-2.0.pc && \
- $(LN_S) -f gtk+-$(GDKTARGET)-2.0.pc gtk+-2.0.pc)
+ cp -f gdk-$(GDKTARGET)-2.0.pc gdk-2.0.pc && \
+ cp -f gtk+-$(GDKTARGET)-2.0.pc gtk+-2.0.pc)
dist-hook: gtk+.spec
if test -e $(srcdir)/INSTALL.in && test -e $(srcdir)/README.in ; then \