summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2011-01-21 17:21:52 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2011-01-21 17:21:52 +0800
commit65cb9548053f61088a70a9bd5fc6f69e9cd86153 (patch)
treeb232d64b2bdcc679b28c3b57807354a52fda1e2f /Makefile.am
parentef5d0cfca3f7cbaa15806daf51b77ea53e403ce2 (diff)
downloadgdk-pixbuf-65cb9548053f61088a70a9bd5fc6f69e9cd86153.tar.gz
Bug 639922: Visual C++ 2008 Project Files
After checking with Tor Lillqvist, these are committed here... They are done in a similar way to what is now in GLib and GTK+, so that if the main GDK-Pixbuf library receives new source files, the new items will be added to gdk-pixbuf.vcproj automatically when a tarball is released via 'make dist'. Note that the main GDK-Pixbuf library can be compiled in 2 variants, one using the native GDI+ APIs from Windows which is supplied with the Windows Platform SDK (but still makes use of LibPNG+ZLib) and another that relies on 3rd-party image manipulation libraries (libTIFF, IJG JPEG and libJasPer [JPEG-2000 library]) like what is used on other platforms AFAIK. In either case the image loaders are built directly into the main GDK-Pixbuf library (i.e. the INCLUDE_<loader> macros are used). This will build and "install" the main GDK-Pixbuf library and the gdk-pixbuf-csource and gdk-pixbuf-query-loaders utility programs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bfb5bfc96..076361168 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@ include $(top_srcdir)/Makefile.decl
SUBDIRS = gdk-pixbuf po docs tests contrib
+EXTRA_DIST += config.h.win32
+
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gdk-pixbuf-2.0.pc