summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndoni Morales Alastruey <ylatuya@gmail.com>2014-09-28 13:21:59 +0200
committerBastien Nocera <hadess@hadess.net>2014-10-22 20:58:50 +0200
commita55aa6ebd4c8a1892bb17b72f3bd18ca90bce01d (patch)
tree7587c749057d1afd10605befe989f66c2eeb5ce0 /configure.ac
parentae7716c83d103fb3d996be5befc715144f6941c0 (diff)
downloadgdk-pixbuf-a55aa6ebd4c8a1892bb17b72f3bd18ca90bce01d.tar.gz
io: extend support for relotations to OS X and Linux
https://bugzilla.gnome.org/show_bug.cgi?id=737523
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 650a63c86..e2c1f6758 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,10 @@ AC_SUBST(EXE_MANIFEST_ARCHITECTURE)
case $host in
*-*-linux*)
os_linux=yes
+ AC_DEFINE(OS_LINUX, 1, [Define to 1 if it's a Linux platform])
+ ;;
+ *-*-darwin*)
+ AC_DEFINE(OS_DARWIN, 1, [Define to 1 if it's a darwin platform])
;;
esac
@@ -1065,6 +1069,28 @@ AC_SUBST(LCOV)
AC_SUBST(GCOV)
AC_SUBST(GENHTML)
+#######################################################
+# Enable replacing the build-time prefix in the loaders
+# cache with the installation prefix on this machine
+# for relocatable packages such as Windows and OS X
+# applicationsapplications and linux bundles
+#######################################################
+
+enable_relocations=no
+case $host in
+ *-*-mingw*)
+ enable_relocations=yes
+ ;;
+ *-*-darwin*)
+ enable_relocations=yes
+ ;;
+esac
+
+if test "x$enable_relocations" = "xyes"; then
+ AC_DEFINE(GDK_PIXBUF_RELOCATABLE, 1,
+ [Define to 1 to replace the build-time prefix in modules])
+fi
+
##################################################
# Output commands
##################################################