summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@gtk.org>1998-06-09 23:18:11 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-06-09 23:18:11 +0000
commit2cabeeb1c3ec0c1a17c4c372191dbe64ce5987af (patch)
tree30c846619e032f4c47a2b4e70ff70b70988ec564 /configure.in
parenta1fe6d0337f1f234a6ac3ece433be960d17a9578 (diff)
downloadgdk-pixbuf-2cabeeb1c3ec0c1a17c4c372191dbe64ce5987af.tar.gz
Removed g_object_pointer_hash, which was just g_direct_hash.
Tue Jun 9 18:44:57 1998 Owen Taylor <otaylor@gtk.org> * gtk/gtkobject.c: Removed g_object_pointer_hash, which was just g_direct_hash. Mon May 25 19:54:20 1998 Owen Taylor <otaylor@gtk.org> * configure.in: x_libs=, not $x_libs=. Enough said. (Case only hit for --disable-xshm) Mon May 25 12:08:14 1998 Owen Taylor <otaylor@gtk.org> * configure.in (LDFLAGS): Add to $CFLAGS and $LDFLAGS when testing for X libraries, don't replace them. Because the user might have specified the path to the X libraries themself before running configure. * examples/**.c: Changed all gpointer * to gpointer Sat May 23 21:54:05 1998 Owen Taylor <otaylor@gtk.org> * configure.in (LDFLAGS): Bomb out with a moderately helpful message if detection of X libraries fails. Sat May 23 18:57:06 1998 Owen Taylor <otaylor@gtk.org> [ Combination of: gtk-rrh-980412-0.patch (Raja R Harinath <harinath@cs.umn.edu>) gtk-jbuhler-980516-0 (Jeremy Buhler <jbuhler@cs.washington.edu>) ] * gdk/gdk.h gdk/gdkcc.c gdk/gdkfont.c gtk/gtkmain.c gtk/gtksignal.c gtk/gtktext.c: Fixups for warnings from adding const to type of GHashFunc, GCompareFunc * gtk/gtkcombo.c (gtk_combo_entry_key_press): Minor style/ ansi-warnings fixups. Tue Jun 9 17:47:33 1998 Owen Taylor <otaylor@gtk.org> * glib.h: Remove #error - HP/UX. Sat May 23 19:00:01 1998 Owen Taylor <otaylor@gtk.org> [ Combination of: gtk-rrh-980412-0.patch (Raja R Harinath <harinath@cs.umn.edu>) gtk-jbuhler-980516-0 (Jeremy Buhler <jbuhler@cs.washington.edu>) ] * glib.h ghash.c gstring.c gdataset.c gutils.c: - Added new typedef g_const_pointer; expunged all incorrect uses of 'const gpointer'. - Fixed up warnings that that created, - Changed GHashFunc and GCompareFunc to take g_const_pointer arguments. (Necessary, but will cause warnings in existing code until fixed) - Added other new const in harmless positions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5311d0008..9aa45647f 100644
--- a/configure.in
+++ b/configure.in
@@ -140,8 +140,8 @@ fi
saved_cflags="$CFLAGS"
saved_ldflags="$LDFLAGS"
-CFLAGS="$X_CFLAGS"
-LDFLAGS="$X_LDFLAGS $X_LIBS"
+CFLAGS="$CFLAGS $X_CFLAGS"
+LDFLAGS="$LDFLAGS $X_LDFLAGS $X_LIBS"
if test "x$no_x" = "xyes"; then
AC_MSG_ERROR([
@@ -170,7 +170,7 @@ fi
AC_CHECK_LIB(Xext, XShapeCombineMask,
if test -z "`echo $x_libs | grep "\-lXext" 2> /dev/null`"; then
- $x_libs="-lXext $x_libs"
+ x_libs="-lXext $x_libs"
fi
AC_DEFINE(HAVE_SHAPE_EXT),
,