summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1999-02-15 06:51:28 +0000
committerTim Janik <timj@src.gnome.org>1999-02-15 06:51:28 +0000
commit3d23ab250e18153fcb39652aa35ac40745dc9509 (patch)
tree1f08888742185e898943d9ef69494dbad499882f /configure.in
parent1f85d83ef357fed2f5dbdcfd99c14dcfbddb0326 (diff)
downloadgdk-pixbuf-3d23ab250e18153fcb39652aa35ac40745dc9509.tar.gz
default to yes for development trees.
Mon Feb 15 07:45:28 1999 Tim Janik <timj@gtk.org> * configure.in (--enable-debug): default to yes for development trees.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index cc5eeb53a..37cb0dc10 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,10 @@ AC_INIT(gdk/gdktypes.h)
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS+set}
+dnl we to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
+dnl are available for $ac_help expansion (don't we all *love* autoconf?)
+AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+#
# Making releases:
# GTK_MICRO_VERSION += 1;
# GTK_INTERFACE_AGE += 1;
@@ -29,6 +33,9 @@ GTK_MICRO_VERSION=15
GTK_INTERFACE_AGE=1
GTK_BINARY_AGE=1
GTK_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$GTK_MICRO_VERSION
+dnl
+AC_DIVERT_POP()dnl
+
AC_SUBST(GTK_MAJOR_VERSION)
AC_SUBST(GTK_MINOR_VERSION)
AC_SUBST(GTK_MICRO_VERSION)
@@ -67,9 +74,20 @@ AM_MAINTAINER_MODE
AC_CANONICAL_HOST
+dnl figure debugging default, prior to $ac_help setup
+dnl
+AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+if test `expr $GTK_MINOR_VERSION \% 2` = 1 ; then
+ debug_default=yes
+else
+ debug_default=minimum
+fi
+AC_DIVERT_POP()dnl
+
+dnl declare --enable-* args and collect ac_help strings
+AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=$debug_default]],,enable_debug=$debug_default)
AC_ARG_ENABLE(shm, [ --enable-shm support shared memory if available [default=yes]],
echo $enable_shm, enable_shm="yes")
-AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=minimum]],,enable_debug=minimum)
AC_ARG_ENABLE(ansi, [ --enable-ansi turn on strict ansi [default=no]],
, enable_ansi=no)
AC_ARG_WITH(glib, [ --with-glib=DIR Use uninstalled copy of glib])