summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@gtk.org>1998-05-16 02:13:12 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-05-16 02:13:12 +0000
commit457148333e72c2bc607268ce4922c531aaf33181 (patch)
tree869e8cb6ad75e382de86fbce844141266171fca2 /configure.in
parent123e299bcf4a86e8078d77d4f3d4367638cded94 (diff)
downloadgdk-pixbuf-457148333e72c2bc607268ce4922c531aaf33181.tar.gz
Basic thread-awareness:
Fri May 15 21:16:54 1998 Owen Taylor <otaylor@gtk.org> Basic thread-awareness: * acconfig.h configure.in: New option --with-threads=[yes/posix/no] * gdk/Makefile.am gdk/gdkthreads.c: Added new functions gdk_threads_[init/enter/leave] for applications, plus gdk_threads_wake to wake the mainloop thread out of the select(). * gtk/Makefile.am: gtk/testthreads.c: Test program for threads Fri May 15 12:08:48 1998 Owen Taylor <otaylor@gtk.org> * gtk/testgtk.c (list_clear): Account for the fact that gtk_list_clear_items is not inclusive. (Clears [start, end))
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8a0baf923..74f23e4f6 100644
--- a/configure.in
+++ b/configure.in
@@ -68,6 +68,7 @@ AC_ARG_ENABLE(xim, [ --enable-xim support XIM [default=yes]],
AC_ARG_WITH(locale, [ --with-locale=LOCALE locale name you want to use ])
AC_ARG_WITH(xinput, [ --with-xinput=[no/gxi/xfree] support XInput ])
+AC_ARG_WITH(threads, [ --with-threads=[posix] support threading ])
if test "x$enable_debug" = "xyes"; then
test "$cflags_set" = set || CFLAGS="$CFLAGS -g"
@@ -183,6 +184,15 @@ else
AC_DEFINE(XINPUT_NONE)
fi
+# Threads
+
+if test "x$with_threads" = "xposix" || test "x$with_threads" = "xyes"; then
+ AC_CHECK_LIB(pthread, pthread_create,
+ AC_DEFINE(USE_PTHREADS)
+ x_libs="$x_libs -lpthread"
+ CFLAGS="$CFLAGS -D_REENTRANT")
+fi
+
AC_SUBST(x_cflags)
AC_SUBST(x_includes)
AC_SUBST(x_ldflags)