summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@src.gnome.org>1998-11-06 22:05:02 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-11-06 22:05:02 +0000
commite2a521922085c8010028e227f61bba59ea6b8242 (patch)
tree2500d6aa6f63aab4b58c17546532ecce8fdcca37 /configure.in
parent3c0df19a588bd96f328bda975db8eb9fa7f79e81 (diff)
downloadgdk-pixbuf-e2a521922085c8010028e227f61bba59ea6b8242.tar.gz
Merge from themes-2. See the ChangeLog for a somewhat detailed
history of the evolution of the changes involved. Most of this is actually minor painting tweaks.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 88e0ba4f8..394fc67c5 100644
--- a/configure.in
+++ b/configure.in
@@ -291,11 +291,19 @@ fi
# Threads
+CFLAGS="$saved_cflags"
+LDFLAGS="$saved_ldflags"
+
if test "x$with_threads" = "xposix" || test "x$with_threads" = "xyes"; then
AC_CHECK_LIB(pthread, pthread_attr_init,
- AC_DEFINE(USE_PTHREADS)
+ [AC_DEFINE(USE_PTHREADS)
x_libs="$x_libs -lpthread"
- CFLAGS="$CFLAGS -D_REENTRANT")
+ CFLAGS="$CFLAGS -D_REENTRANT"],
+ # AIX has libpthreads, cause they're special. Special friends (TM)
+ AC_CHECK_LIB(pthreads, pthread_attr_init,
+ [AC_DEFINE(USE_PTHREADS)
+ x_libs="$x_libs -lpthreads"
+ CFLAGS="$CFLAGS -D_REENTRANT -D_THREAD_SAFE"]))
fi
AC_SUBST(x_cflags)
@@ -304,9 +312,6 @@ AC_SUBST(x_ldflags)
AC_SUBST(x_libs)
AC_SUBST(xinput_progs)
-CFLAGS="$saved_cflags"
-LDFLAGS="$saved_ldflags"
-
if test "x$enable_shm" = "xyes"; then
# Check for shared memory
AC_CHECK_HEADER(sys/ipc.h, AC_DEFINE(HAVE_IPC_H), no_sys_ipc=yes)
@@ -408,9 +413,6 @@ AC_HEADER_STDC
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
-# Checks for endianness (needed by GdkRgb).
-AC_C_BIGENDIAN
-
# Checks for library functions.
AC_TYPE_SIGNAL
AC_FUNC_MMAP