summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1998-05-11 08:31:16 +0000
committerTim Janik <timj@src.gnome.org>1998-05-11 08:31:16 +0000
commite8df8ce17b22541b2cb4a4e00628e85f1df7441f (patch)
tree5ecd187d297b9f1c9e6abcdd9492df019edd3bdc /configure.in
parent01003779e99dc6f0cc553993d56d876bfec60a44 (diff)
downloadgdk-pixbuf-e8df8ce17b22541b2cb4a4e00628e85f1df7441f.tar.gz
preserve automake CFLAGS.
Mon May 11 09:56:45 1998 Tim Janik <timj@gtk.org> * configure.in (cflags_set): preserve automake CFLAGS. * Makefile.am: fully rename the created libraries to libgtk-1.1.la and libgdk-1.1.la. this means we need to change certain portions of the Makefile.am on major/minor version bumps. * ltmain.sh: the -release option is not required anymore. * gtk/gtkobject.h (gtk_trace_referencing): compile time check the type of the first argument to be of type GtkObject. unconditionally compile this function. removed __GNUC__ dependancy of the gtk_object_ref and gtk_object_unref macro wrappers for this function. Mon May 11 09:53:43 1998 Tim Janik <timj@gtk.org> * configure.in: preserve automake CFLAGS. * Makefile.am: fully rename the created library to libglib-1.1.la. this means we need to change certain portions of the Makefile.am on major/minor version bumps. * ltmain.sh: the -release option is not required anymore. * glib.h: provide G_GNUC_FUNCTION and G_GNUC_PRETTY_FUNCTION to avoid conditionals. unconditionally define NULL, TRUE, FALSE, MAX, MIN, ABS and CLAMP, these macros might be screwed from other headers.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fa956c4a2..8a0baf923 100644
--- a/configure.in
+++ b/configure.in
@@ -70,7 +70,7 @@ AC_ARG_WITH(locale, [ --with-locale=LOCALE locale name you want to use ])
AC_ARG_WITH(xinput, [ --with-xinput=[no/gxi/xfree] support XInput ])
if test "x$enable_debug" = "xyes"; then
- test "$cflags_set" = set || CFLAGS="-g"
+ test "$cflags_set" = set || CFLAGS="$CFLAGS -g"
CFLAGS="$CFLAGS -DG_ENABLE_DEBUG"
else
if test "x$enable_debug" = "xno"; then