summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorManish Singh <yosh@src.gnome.org>1998-12-15 07:08:05 +0000
committerManish Singh <yosh@src.gnome.org>1998-12-15 07:08:05 +0000
commit58475f05a54f7a165fe92adf8358f59cf0223c08 (patch)
tree5cc1a1987643794719c743a309c2455665b05709 /configure.in
parent30b9a28779018a28453e6dc9eac7c078acadafbe (diff)
downloadgdk-pixbuf-58475f05a54f7a165fe92adf8358f59cf0223c08.tar.gz
acconfig.h removed IPC_RMID_DEFERRED_RELEASE check
* acconfig.h * configure.in: removed IPC_RMID_DEFERRED_RELEASE check * gdk/gdk.c: remove signal handlers, since we do an IPC_RMID after XShmAttach, and nobody complained -Yosh
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index b4f24e086..b0ede74d8 100644
--- a/configure.in
+++ b/configure.in
@@ -333,38 +333,6 @@ if test "x$enable_shm" = "xyes"; then
AC_CHECK_HEADER(sys/ipc.h, AC_DEFINE(HAVE_IPC_H), no_sys_ipc=yes)
AC_CHECK_HEADER(sys/shm.h, AC_DEFINE(HAVE_SHM_H), no_sys_shm=yes)
- # Check whether shmctl IPC_RMID allowes subsequent attaches
- if test "$ac_cv_header_sys_shm_h" = "yes"; then
- AC_MSG_CHECKING(whether shmctl IPC_RMID allowes subsequent attaches)
- AC_TRY_RUN([
- #include <sys/types.h>
- #include <sys/ipc.h>
- #include <sys/shm.h>
- int main()
- {
- int id;
- char *shmaddr;
- id = shmget (IPC_PRIVATE, 4, IPC_CREAT | 0777);
- if (id == -1)
- exit (2);
- shmaddr = shmat (id, 0, 0);
- shmctl (id, IPC_RMID, 0);
- if ((char*) shmat (id, 0, 0) == (char*) -1)
- {
- shmdt (shmaddr);
- exit (1);
- }
- shmdt (shmaddr);
- shmdt (shmaddr);
- exit (0);
- }
- ],
- AC_DEFINE(IPC_RMID_DEFERRED_RELEASE)
- AC_MSG_RESULT(yes),
- AC_MSG_RESULT(no),
- AC_MSG_RESULT(assuming no))
- fi
-
# Check for the X shared memory extension header file
AC_MSG_CHECKING(X11/extensions/XShm.h)
if test "x$no_xext_lib" = "xyes"; then