summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-01-16 15:31:42 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-01-16 15:31:42 +0000
commit476d48ddd1a3c0916e32885caeb02cf13dcfcf6f (patch)
tree894b52a609182a2ab85c3caeb1a398c88165ba96 /configure.in
parent37d1686ac675d096657a2559270b82c09654a6cd (diff)
downloadgdk-pixbuf-476d48ddd1a3c0916e32885caeb02cf13dcfcf6f.tar.gz
Add gtkstockpixbufs.h.
Wed Jan 16 10:18:42 2002 Owen Taylor <otaylor@redhat.com> * gtk/stock-icons/Makefile.am (EXTRA_DIST): Add gtkstockpixbufs.h. * configure.in: Make TIFF, JPEG, PNG loaders mandatory unless you configure with --without-libtiff, etc. (#54045, Brian Cameron)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 32 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 195d9af39..a59167a9d 100644
--- a/configure.in
+++ b/configure.in
@@ -591,8 +591,15 @@ else
AC_MSG_RESULT(no)
fi
+dnl We allow people to disable image loaders explicitely, but if they don't we error
+dnl out so that people don't accidentally build without them.
+
+AC_ARG_WITH(libpng, [ --without-libpng Disable PNG loader for gdk-pixbuf])
+AC_ARG_WITH(libjpeg, [ --without-libjpeg Disable JPEG loader for gdk-pixbuf])
+AC_ARG_WITH(libtiff, [ --without-libjpeg Disable TIFF loader for gdk-pixbuf])
+
dnl Test for libtiff
- if test -z "$LIBTIFF"; then
+ if test x$with_libtiff != xno && test -z "$LIBTIFF"; then
AC_CHECK_LIB(tiff, TIFFReadScanline,
[AC_CHECK_HEADER(tiffio.h,
TIFF='tiff'; LIBTIFF='-ltiff',
@@ -608,8 +615,15 @@ dnl Test for libtiff
AC_MSG_WARN(*** TIFF plug-in will not be built (TIFF library not found) ***), -ljpeg -lz -lm)], -ljpeg -lz -lm)], -lm)
fi
+ if test x$with_libtiff != xno && test -z "$LIBTIFF"; then
+ AC_MSG_ERROR([
+*** Checks for TIFF loader failed. You can build without it by passing
+*** --without-libtiff to configure but some programs using GTK+ may
+*** not work properly])
+ fi
+
dnl Test for libjpeg
- if test -z "$LIBJPEG"; then
+ if test x$with_libjpeg != xno && test -z "$LIBJPEG"; then
AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
jpeg_ok=yes,
jpeg_ok=no
@@ -636,8 +650,15 @@ dnl Test for libjpeg
fi
fi
+ if test x$with_libjpeg != xno && test -z "$LIBJPEG"; then
+ AC_MSG_ERROR([
+*** Checks for JPEG loader failed. You can build without it by passing
+*** --without-libjpeg to configure but some programs using GTK+ may
+*** not work properly])
+ fi
+
dnl Test for libpng
- if test -z "$LIBPNG"; then
+ if test x$with_libpng != xno && test -z "$LIBPNG"; then
AC_CHECK_LIB(png, png_read_info,
[AC_CHECK_HEADER(png.h,
png_ok=yes,
@@ -660,6 +681,14 @@ dnl Test for libpng
fi
fi
+ if test x$with_libpng != xno && test -z "$LIBPNG"; then
+ AC_MSG_ERROR([
+*** Checks for PNG loader failed. You can build without it by passing
+*** --without-libpng to configure but many programs using GTK+ will
+*** not work properly. The PNG loader is also needed if you are compiling
+*** from CVS.])
+ fi
+
AC_SUBST(LIBTIFF)
AC_SUBST(LIBJPEG)
AC_SUBST(LIBPNG)