summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <maclas@gmx.de>2003-06-17 00:37:28 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2003-06-17 00:37:28 +0000
commitfcffe5a1abb031909e85a8b5b2f1adbe587389ed (patch)
treeb86fa96d53bddea9393af8d416f3d01a4a9b0b56 /configure.in
parent5e4a3fbab16b7b71f4966a7e16ca8213e70a8340 (diff)
downloadgdk-pixbuf-fcffe5a1abb031909e85a8b5b2f1adbe587389ed.tar.gz
Add rule to regenerate man pages from Docbook. (man_MANS): Add
2003-06-17 Matthias Clasen <maclas@gmx.de> * gdk-pixbuf/Makefile.am: Add rule to regenerate man pages from Docbook. (man_MANS): Add gdk-pixbuf-csource.1, gdk-pixbuf-query-loaders.1. (content_files): Add gdk-pixbuf-csource.xml, gdk-pixbuf-query-loaders.xml. * gdk-pixbuf/gdk-pixbuf-csource.xml: New refentry, containing the former gdk-pixbuf/gdk-pixbuf-csource.1, converted to Docbook. * gdk-pixbuf/gdk-pixbuf-query-loaders.xml: New refentry. * gdk-pixbuf/gdk-pixbuf-csource.1: * gdk-pixbuf/gdk-pixbuf-query-loaders.1: Man pages generated from the .xml sources. * gdk-pixbuf/gdk-pixbuf.sgml: Include gdk-pixbuf-csource.xml and gdk-pixbuf-query-loaders.xml. * gtk/Makefile.am: Add rule to regenerate man pages from Docbook. (man_MANS): Add gtk-query-immodules-2.0.1 (content_files): Add gtk-query-immodules-2.0.xml * gtk/gtk-query-immodules-2.0.xml: New refentry. * gtk/gtk-query-immodules-2.0.1: Man page generated from the .xml source. * gtk/gtk-docs.sgml: Include gtk-query-immodules-2.0.xml. * acinclude.m4 (JH_PATH_XML_CATALOG, JH_CHECK_XML_CATALOG): New macros to check for XML catalog contents and path, borrowed from gtk-doc. * configure.in: New option --enable-man to enable regeneration of man pages from Docbook, if the necessary tools are found.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 674b3c9ac..a28660a6c 100644
--- a/configure.in
+++ b/configure.in
@@ -1467,6 +1467,26 @@ GTK_DOC_CHECK([1.0])
AC_CHECK_PROG(DB2HTML, db2html, true, false)
AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
+AC_ARG_ENABLE(man,
+ [AC_HELP_STRING([--enable-man],
+ [regenerate man pages from Docbook [default=no]])],enable_man=yes,
+ enable_man=no)
+
+dnl
+dnl Check for xsltproc
+dnl
+AC_PATH_PROG([XSLTPROC], [xsltproc])
+if test -z "$XSLTPROC"; then
+ enable_man=no
+fi
+
+dnl check for DocBook DTD and stylesheets in the local catalog.
+JH_CHECK_XML_CATALOG([-//OASIS//DTD DocBook XML V4.1.2//EN],
+ [DocBook XML DTD V4.1.2],,enable_man=no)
+JH_CHECK_XML_CATALOG([http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl],
+ [DocBook XSL Stylesheets],,enable_man=no)
+AM_CONDITIONAL(ENABLE_MAN, test x$enable_man != xno)
+
##################################################
# Output commands
##################################################