summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-09-11 20:24:40 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-09-11 20:24:40 +0000
commit69915aa7104beebdcfbc6d42592481843069c403 (patch)
tree933c4c9172a34de05399eb080a541c0bd6254979 /configure.in
parent13ff590365e84e5470c72bf42bab98177fbc167f (diff)
downloadgdk-pixbuf-69915aa7104beebdcfbc6d42592481843069c403.tar.gz
Implement a search path for GTK+ modules.
Sat Sep 8 16:19:02 2001 Owen Taylor <otaylor@redhat.com> * gtk/gtkmain.c: Implement a search path for GTK+ modules. * configure.in gtk/gtkrc.c gtk/Makefile.am: Look for modules in gtk-2.0/<type>/major.minor.(micro-binary_age) rather than in gtk-2.0/major.minor.micro/<type>/. This works better for a search path for modules. * gtk+-2.0.pc.in gtk+-2.0-uninstalled.pc.in: Add gtk_binary_version variable holding major.minor.(micro-binary_age). * modules/input/Makefile.am (moduledir): Fix installation directory to match change in lookup location. * gtk/gtkmain.c (gtk_init_check): Remove OS/2 code for dll suffixes. Needs to be handled in g_module_build_path(). * gtk/gtkrc.c gtk/queryimmodules.c: Use g_build_filename() where appropriate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 59beb590d..4f1ee278a 100644
--- a/configure.in
+++ b/configure.in
@@ -58,6 +58,12 @@ AC_SUBST(LT_CURRENT)
AC_SUBST(LT_REVISION)
AC_SUBST(LT_AGE)
+# Define a string for the earliest version that this release has
+# binary compatibility with. This is used for module locations.
+#
+GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
+AC_SUBST(GTK_BINARY_VERSION)
+
#
# gdk-pixbuf gets versioned separately, and for now, using standard
# libtool versioning, not GTK+-style versioning