summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@gtk.org>1998-05-24 02:48:09 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-05-24 02:48:09 +0000
commit23919bb08cdc86d6bd53e614499559f44ef794cb (patch)
tree641caf310c525c0ed5696e8c8b8c37f657ad993f /configure.in
parent53d06396b835233d87a06ebd7f86418b5418f19c (diff)
downloadgdk-pixbuf-23919bb08cdc86d6bd53e614499559f44ef794cb.tar.gz
Bombo out with a moderately helpful message if detection of X libraries
Sat May 23 21:54:05 1998 Owen Taylor <otaylor@gtk.org> * configure.in (LDFLAGS): Bombo out with a moderately helpful message if detection of X libraries fails.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index be02f4e1f..5311d0008 100644
--- a/configure.in
+++ b/configure.in
@@ -143,9 +143,17 @@ saved_ldflags="$LDFLAGS"
CFLAGS="$X_CFLAGS"
LDFLAGS="$X_LDFLAGS $X_LIBS"
+if test "x$no_x" = "xyes"; then
+ AC_MSG_ERROR([
+*** X libraries or include files not found. Check 'config.log' for
+*** more details.])
+fi
+
# Checks for libraries.
# Check for the X11 library
-AC_CHECK_LIB(X11, XOpenDisplay, x_libs="-lX11 $X_EXTRA_LIBS", no_x11_lib=yes, $X_EXTRA_LIBS)
+AC_CHECK_LIB(X11, XOpenDisplay, x_libs="-lX11 $X_EXTRA_LIBS",
+ AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]),
+ $X_EXTRA_LIBS)
if test "x$enable_shm" = "xyes"; then
# Check for the Xext library (needed for XShm extention)