summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2004-11-12 19:48:43 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-11-12 19:48:43 +0000
commit3b9a31df075d4a53aaf1d592adc81a0dfc8996f7 (patch)
tree61f66747e5c94cdbfb489e3dd1e11c3072cc14db /configure.in
parent888aeacf51f4a60d0c5120b027f51c540f862d40 (diff)
downloadgdk-pixbuf-3b9a31df075d4a53aaf1d592adc81a0dfc8996f7.tar.gz
Make GDK+ compile with X11R5 (#148032)
2004-11-12 Matthias Clasen <mclasen@redhat.com> Make GDK+ compile with X11R5 (#148032) * gdk/x11/xsettings-client.c (xsettings_client_new): * gdk/x11/gdkproperty-x11.c (_gdk_x11_precache_atoms): Only use XInternAtoms if it is available. * gdk/x11/gdkasync.c: Include XIproto.h if necessary. * configure.in: Check for XInternAtoms and X headers needed for xReply.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 30 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3706d3ee1..f3cc063a3 100644
--- a/configure.in
+++ b/configure.in
@@ -1150,6 +1150,26 @@ if test "x$gdktarget" = "xx11"; then
CPPFLAGS="$gtk_save_cppflags"
+ # Check for xReply
+
+ gtk_save_cppflags="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+
+ AC_MSG_CHECKING([if <X11/extensions/XIproto.h> is needed for xReply])
+ AC_TRY_COMPILE([#include <X11/Xlibint.h>],
+ [xReply *rep;],
+ [AC_MSG_RESULT([no])],
+ [AC_TRY_COMPILE([#include <X11/extensions/XIproto.h>
+#include <X11/Xlibint.h>],
+ [xReply *rep;],
+ [AC_MSG_RESULT([yes])
+ AC_DEFINE([NEED_XIPROTO_H_FOR_XREPLY], 1,
+ [Define if <X11/extensions/XIproto.h> needed for xReply])],
+ [AC_MSG_RESULT([unknown])
+ AC_MSG_ERROR([xReply type unavailable. X11 is too old])])])
+
+ CPPFLAGS="$gtk_save_cppflags"
+
# Check for shaped window extension
AC_CHECK_LIB(Xext, XShapeCombineMask,
@@ -1165,10 +1185,18 @@ if test "x$gdktarget" = "xx11"; then
,
$x_libs_for_checks)
+ # Check for XInternAtoms (X11R6 specific)
+
+ AC_CHECK_LIB(X11, XInternAtoms,
+ AC_DEFINE([HAVE_XINTERNATOMS], 1,
+ [Define to 1 if you have the `XInternAtoms' function.]),
+ ,
+ $x_libs_for_checks)
+
# Generic X11R6 check needed for XIM support; we could
# probably use this to replace the above, but we'll
- # leave the separate XConvertCase check for clarity
-
+ # leave the separate checks for XConvertCase and XInternAtoms
+ # for clarity
have_x11r6=false
AC_CHECK_LIB(X11, XAddConnectionWatch,
have_x11r6=true,