summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@gtk.org>1998-06-10 23:44:55 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-06-10 23:44:55 +0000
commit7086e475e3fc26279f004a6cff69cd4dfbd079b4 (patch)
tree0ac4f76502e335e7c96a7d6fea98c6e6a792d72a /configure.in
parent6b61461a404b910f9024299fd97fc9cb2423d781 (diff)
downloadgdk-pixbuf-7086e475e3fc26279f004a6cff69cd4dfbd079b4.tar.gz
glib/* Moved to glib module
Wed Jun 10 19:36:35 1998 Owen Taylor <otaylor@gtk.org> * glib/* Moved to glib module * INSTALL Makefile.am acconfig.h autogen.sh configure.in gtk-config.in gtk.m4 gdk/Makefile.am gtk/Makefile.am configuration changes for the above: - Use AM_PATH_GLIB by default to find glib; also accept a --with-glib option for using an uninstalled glib. - Put --enable-debug information into config.h so that we rebuild when it changes. (was in glibconfig.h)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in56
1 files changed, 53 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 9aa45647f..20021703c 100644
--- a/configure.in
+++ b/configure.in
@@ -38,9 +38,6 @@ AC_SUBST(LT_AGE)
VERSION=$GTK_VERSION
PACKAGE=gtk+
-# Configure glib
-AC_CONFIG_SUBDIRS(glib)
-
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS+set}
@@ -63,6 +60,7 @@ AC_ARG_ENABLE(shm, [ --enable-shm support shared memory if available
AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=minimum]],,enable_debug=minimum)
AC_ARG_ENABLE(ansi, [ --enable-ansi turn on strict ansi [default=no]],
, enable_ansi=no)
+AC_ARG_WITH(glib, [ --with-glib=DIR Use uninstalled copy of glib])
AC_ARG_ENABLE(xim, [ --enable-xim support XIM [default=yes]],
echo $enable_xim, enable_xim="yes")
AC_ARG_WITH(locale, [ --with-locale=LOCALE locale name you want to use ])
@@ -81,6 +79,8 @@ else
fi
fi
+AC_DEFINE_UNQUOTED(GTK_COMPILED_WITH_DEBUGGING, "${enable_debug}")
+
# Build time sanity check...
AM_SANITY_CHECK
@@ -129,6 +129,56 @@ if test "x$enable_xim" = "xyes"; then
CFLAGS="$CFLAGS -DUSE_XIM"
fi
+if test x$with_glib = xyes ; then
+ AC_MSG_ERROR([
+*** Directory must be specified for --with-glib])
+fi
+
+if test x$with_glib = x ; then
+ # Look for separately installed glib
+
+ AM_PATH_GLIB(1.1.0,,
+ AC_MSG_ERROR([
+*** GLIB 1.1.0 or better is required. The latest version of GLIB
+*** is always available from ftp://ftp.gtk.org.]))
+
+ glib_cflags=$GLIB_CFLAGS
+ glib_libs=$GLIB_LIBS
+else
+ # Use uninstalled glib (assume they got the version right)
+
+ if test -x $with_glib/glib-config ; then
+ :
+ else
+ AC_MSG_ERROR([GLIB directory ($with_glib) not present or not configured])
+ fi
+
+ # For use in gtk-config
+ glib_cflags=`$with_glib/glib-config --cflags`
+ glib_libs=`$with_glib/glib-config --libs`
+
+ glib_release=`$with_glib/glib-config --version | sed 's%\\.[[0-9]]*$%%'`
+
+ # canonicalize relative paths
+ case $with_glib in
+ /*)
+ glib_dir=$with_glib
+ ;;
+ *)
+ glib_dir="\$(top_builddir)/$with_glib"
+ ;;
+ esac
+
+ GLIB_CFLAGS="-I$glib_dir"
+ GLIB_LIBS=$glib_dir/libglib-$glib_release.la
+
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+fi
+
+AC_SUBST(glib_cflags)
+AC_SUBST(glib_libs)
+
# Find the X11 include and library directories
AC_PATH_X
AC_PATH_XTRA