summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-02 20:08:39 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-02 20:08:39 +0000
commitdfe5724765acc217ce43b4f96cc0d6dc2d73016c (patch)
treef4f403cf19baee12aa491a678383cae27ccade37 /configure.in
parentf832e3484d146343e6f6bf4b36c4f19746f521f2 (diff)
downloadgdk-pixbuf-dfe5724765acc217ce43b4f96cc0d6dc2d73016c.tar.gz
Default to --disable-gtk-doc (avoid Jade breakage) and --disable-static
Sat Mar 2 14:32:50 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Default to --disable-gtk-doc (avoid Jade breakage) and --disable-static (static linking causes problems with Xft changes.) * autogen.sh: Add --enable-gtk-doc by default. * Makefile.am: Add a 'mydistcheck' rule that passes --enable-gtk-doc to the configure since that is needed for 'make dist'. * docs/tutorial/Makefile.am (dist-hook): Don't distribute the PDF file. (Rule doesn't work on my system, plus it's big.) * gtk/Makefile.am: 'make dist' fixes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 32727570d..90bb9c9d2 100644
--- a/configure.in
+++ b/configure.in
@@ -103,6 +103,7 @@ AM_CONFIG_HEADER(config.h)
dnl Initialize libtool
AC_PROG_CC
+AM_DISABLE_STATIC
AC_LIBTOOL_WIN32_DLL
AM_PROG_LIBTOOL
@@ -277,7 +278,6 @@ AC_SUBST(LIBTOOL_EXPORT_OPTIONS)
# define a MAINT-like variable REBUILD which is set if Perl
# and awk are found, so autogenerated sources can be rebuilt
-AC_PROG_AWK
AC_CHECK_PROGS(PERL, perl5 perl)
# We would like indent, but don't require it.
@@ -286,8 +286,7 @@ AC_CHECK_PROG(INDENT, indent, indent)
REBUILD=\#
if test "x$enable_rebuilds" = "xyes" && \
test -n "$PERL" && \
- $PERL -e 'exit !($] >= 5.002)' > /dev/null 2>&1 && \
- test -n "$AWK" ; then
+ $PERL -e 'exit !($] >= 5.002)' > /dev/null 2>&1 ; then
REBUILD=
fi
AC_SUBST(REBUILD)
@@ -1189,13 +1188,11 @@ fi
AC_CHECK_PROG(DB2HTML, db2html, true, false)
AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
-dnl Let people disable the gtk-doc stuff.
-AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc use gtk-doc to build documentation [default=auto]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
+dnl Make people enable the gtk-doc stuff explicitely.
+AC_ARG_ENABLE(gtk-doc, [ --enable-gtk-doc use gtk-doc to build documentation [default=no]], enable_gtk_doc="$enableval", enable_gtk_doc=auto)
-if test x$enable_gtk_doc = xauto ; then
- if test x$GTKDOC = xtrue ; then
- enable_gtk_doc=yes
- else
+if test x$enable_gtk_doc = xyes ; then
+ if test x$GTKDOC != xtrue ; then
enable_gtk_doc=no
fi
fi