summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMatthias Clasen <matthiasc@src.gnome.org>2002-11-21 20:19:01 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2002-11-21 20:19:01 +0000
commitd20ce3a1d8bbd38c2d43ce0e03670fb016217001 (patch)
tree6303e6e6c647d1801f45aa1e8d54599c23395689 /configure.in
parent6bcfec7d684f7c94fcd5ae87f0b16844a33c2da9 (diff)
downloadgdk-pixbuf-d20ce3a1d8bbd38c2d43ce0e03670fb016217001.tar.gz
Add package version info to API docs.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 99cff557a..a2bb77494 100644
--- a/configure.in
+++ b/configure.in
@@ -615,11 +615,24 @@ AC_MSG_RESULT($gdk_working_wctype)
AC_SUBST(GDK_WLIBS)
-
##################################################
# Checks for gdk-pixbuf
##################################################
+dnl ********************************************************
+dnl * See whether we need to load our modules as .la files *
+dnl ********************************************************
+
+use_la_modules=false
+case $host in
+ *-aix*) use_la_modules=true
+esac
+
+if $use_la_modules ; then
+ AC_DEFINE(USE_LA_MODULES, 1, [Whether to load modules via .la files rather than directly])
+fi
+
+
AC_MSG_CHECKING(whether to build gmodulized gdk-pixbuf)
AC_ARG_ENABLE(modules, [ --disable-modules disable dynamic module loading],[
@@ -1575,8 +1588,11 @@ tests/Makefile
docs/Makefile
docs/reference/Makefile
docs/reference/gdk-pixbuf/Makefile
+docs/reference/gdk-pixbuf/version.xml
docs/reference/gdk/Makefile
+docs/reference/gdk/version.xml
docs/reference/gtk/Makefile
+docs/reference/gtk/version.xml
docs/faq/Makefile
docs/tutorial/Makefile
gdk-pixbuf/Makefile