summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2000-12-15 01:46:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2000-12-15 01:46:41 +0000
commit6e5a269f38ad682e116e94efac287fa4ddc46b7f (patch)
tree25b336984ac15be84beb85ff71b3d99c11b861ed /configure.in
parent2142a98c9e8826323941ec3da2c75325ca00eb52 (diff)
downloadgdk-pixbuf-6e5a269f38ad682e116e94efac287fa4ddc46b7f.tar.gz
Add two virtualized functions gdk_drawable_get_clip_region - to get the
Thu Dec 14 20:22:31 2000 Owen Taylor <otaylor@redhat.com> * gdk/{gdkdrawable.[ch],gdkpixmap.c,gdkwindow.c,x11/gdkwindow.c}: Add two virtualized functions gdk_drawable_get_clip_region - to get the clip region when drawing. * gdk/gdkwindow.c (gdk_window_invalidate_rect): Rewrite to simple use invalidate_region. * gdk/gdkwindow.c (gdk_window_invalidate_region): Clip to visible region. * acconfig.h configure.in: Check for Xft. For now, assume that if Xft is found, Pango was compiled with Xft support as well. * gdk/gdkcolor.h gdk/x11/gdkcolor-x11.c: Add gdk_colormap_query_color(). * gdk/x11/gdkdrawable-x11.c (gdk_x11_draw_glyphs): Draw with Xft if appropriate. * gdk/x11/gdkpango-x11.c (gdk_pango_context_get): Create a pangoxft context if we have XFT and the environment variable GD_USE_XFT is set. * gdk/x11/gdkx.h (struct _GdkGCX11): Cache the fg_pixel and also possibly an XftDraw structure. * gtk/gtkfontsel.c: Handle the case where the font from the style doesn't match any of the fonts a bit better. * gtk/testgtk.c: Add tabs between directional segments for hebrew/arabic test. (Not really necessary, just a little prettier.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2846aab07..7e4bb057a 100644
--- a/configure.in
+++ b/configure.in
@@ -398,6 +398,22 @@ if test "x$gdktarget" = "xx11"; then
,
$x_libs)
+ #
+ # Checks for Xft/XRender
+ #
+ have_xft=false
+ XFT_LIBS=""
+ AC_CHECK_LIB(Xrender, XRenderFindFormat,
+ AC_CHECK_LIB(Xft, XftFontOpen, have_xft=true, :, -lXrender $X_LIBS)
+ ,:,-lXext $X_LIBS)
+
+ if $have_xft = 'true' ; then
+ X_LIBS="-lXft -lXrender -lXext $X_LIBS"
+ fi
+
+ AC_DEFINE(HAVE_XFT)
+ AM_CONDITIONAL(HAVE_XFT, $have_xft)
+
# Check for XIM support.
AC_CHECK_LIB(X11, XUnregisterIMInstantiateCallback,
@@ -562,6 +578,9 @@ fi
if test "x$gdktarget" = "xx11"; then
PANGO_CFLAGS="`$PANGO_CONFIG --cflags pangox`"
PANGO_LIBS="`$PANGO_CONFIG --libs pangox`"
+ if $have_xft = true ; then
+ PANGO_LIBS="$PANGO_LIBS -lpangoxft"
+ fi
else
PANGO_CFLAGS="`$PANGO_CONFIG --cflags pango`"
PANGO_LIBS="`$PANGO_CONFIG --libs pango`"