summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-07-09 00:10:12 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-07-09 00:10:12 +0000
commitc0dace5fd9deb9197415ba7c994f392acdfde0ea (patch)
tree14ae690ab3aeab5bdaa9b3da054f8a8b5f37dc6c /configure.in
parent13d49dd3d1981591554262b46e3ab633dd64db75 (diff)
downloadgdk-pixbuf-c0dace5fd9deb9197415ba7c994f392acdfde0ea.tar.gz
Look for windres on Win32.
2005-07-09 Tor Lillqvist <tml@novell.com> * configure.in: Look for windres on Win32. * gdk-pixbuf/Makefile.am * gdk/win32/rc/Makefile.am * gdk/Makefile.am * gtk/Makefile.am: Don't use the scripts in build/win32 to compile the rc files into resource object files. (This means we lose the build number increment magic, but I doubt it was that useful anyway.) Instead use windres directly. To pass a normal .o file produced by windres through libtool, which would want a .lo file, pass it directly to the linker using a -Wl option. * gdk-pixbuf/gdk_pixbuf.rc.in * gdk/win32/rc/gdk.rc.in * gtk/gtk-win32.rc.in: Replace BUILDNUMBER with 0.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 99adba0fe..af7098bfb 100644
--- a/configure.in
+++ b/configure.in
@@ -174,6 +174,10 @@ AM_CONDITIONAL(OS_UNIX, test "$os_win32" != "yes")
AM_CONDITIONAL(OS_LINUX, test "$os_linux" = "yes")
if test "$os_win32" = "yes"; then
+ AC_CHECK_TOOL(WINDRES, windres, no)
+ if test "$WINDRES" = no; then
+ AC_MSG_ERROR([*** Could not find an implementation of windres in your PATH.])
+ fi
AC_CHECK_PROG(ms_librarian, lib.exe, yes, no)
fi
AM_CONDITIONAL(MS_LIB_AVAILABLE, test x$ms_librarian = xyes)