summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1998-05-07 04:04:15 +0000
committerTim Janik <timj@src.gnome.org>1998-05-07 04:04:15 +0000
commit39ff37dc74f4e3a5f0eedbcab5a2c7c232d761e9 (patch)
tree311f7a366a88b39e2576150bb54e818f30468eb2 /configure.in
parent91d3176504f1a52f7211fcb20b9b33bd12472d09 (diff)
downloadgdk-pixbuf-39ff37dc74f4e3a5f0eedbcab5a2c7c232d761e9.tar.gz
postfix -lg* libraries with LT_RELEASE.
Thu May 7 05:14:19 1998 Tim Janik <timj@gtk.org> * gtk-config.in (--libs): postfix -lg* libraries with LT_RELEASE. * ltmain.sh: added a new commandline flag -postfix similar to -release, but will immediately change the library name. * gdk/Makefile.am: * gtk/Makefile.am: specify -postfix and -version-info * configure.in: version bump to 1.1.0. added GTK_INTERFACE_AGE and GTK_BINARY_AGE. calculate LT_* variables for libtool.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 72bb6fb1c..30dabb4d5 100644
--- a/configure.in
+++ b/configure.in
@@ -4,10 +4,32 @@ AC_INIT(gdk/gdktypes.h)
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS+set}
+# Making releases:
+# GTK_MICRO_VERSION += 1;
+# GTK_INTERFACE_AGE += 1;
+# GTK_BINARY_AGE += 1;
+# if any functions have been added, set GTK_INTERFACE_AGE to 0.
+# if backwards compatibility has been broken,
+# set GTK_BINARY_AGE and GTK_INTERFACE_AGE to 0.
+#
GTK_MAJOR_VERSION=1
-GTK_MINOR_VERSION=0
+GTK_MINOR_VERSION=1
GTK_MICRO_VERSION=0
+GTK_INTERFACE_AGE=0
+GTK_BINARY_AGE=0
GTK_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$GTK_MICRO_VERSION
+AC_SUBST(GTK_VERSION)
+
+# libtool versioning
+LT_RELEASE=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION
+LT_CURRENT=`expr $GTK_MICRO_VERSION - $GTK_INTERFACE_AGE`
+LT_REVISION=$GTK_INTERFACE_AGE
+LT_AGE=`expr $GTK_BINARY_AGE - $GTK_INTERFACE_AGE`
+AC_SUBST(LT_RELEASE)
+AC_SUBST(LT_CURRENT)
+AC_SUBST(LT_REVISION)
+AC_SUBST(LT_AGE)
+
# For automake.
VERSION=$GTK_VERSION
@@ -149,7 +171,6 @@ AC_SUBST(x_includes)
AC_SUBST(x_ldflags)
AC_SUBST(x_libs)
AC_SUBST(xinput_progs)
-AC_SUBST(GTK_VERSION)
CFLAGS="$saved_cflags"
LDFLAGS="$saved_ldflags"