summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2001-06-07 16:40:01 +0000
committerHavoc Pennington <hp@src.gnome.org>2001-06-07 16:40:01 +0000
commit5aba82da8ffda12f94ef2064b2eb296a9fd5fb60 (patch)
treea840d9f1895e0cc8db4f559ebc116b4c52f6fee7 /configure.in
parent2d18f2f420b165b6c52f320185cd276ef2e56835 (diff)
downloadgdk-pixbuf-5aba82da8ffda12f94ef2064b2eb296a9fd5fb60.tar.gz
subst GLIB_GENMARSHAL, GOBJECT_QUERY, GLIB_MKENUMS variables
2001-06-07 Havoc Pennington <hp@redhat.com> * m4macros/glib-2.0.m4: subst GLIB_GENMARSHAL, GOBJECT_QUERY, GLIB_MKENUMS variables * gmodule-2.0.pc.in: add gmodule_supported variable * glib-2.0.pc.in: add glib_genmarshal, gobject_query, glib_mkenums variables * configure.in: put G_MODULE_SUPPORTED value into .pc files * autogen.sh: support AUTOGEN_SUBDIR_MODE * Makefile.am: add -uninstalled.pc.in to EXTRA_DIST 2001-06-07 Havoc Pennington <hp@redhat.com> * pango/Makefile.am: add libpango.la to _DEPENDENCIES for the other libs * configure.in: use AM_PATH_GLIB_2_0 * autogen.sh: support AUTOGEN_SUBDIR_MODE * Makefile.am: dist the .pc.in files 2001-06-07 Havoc Pennington <hp@redhat.com> * atk/Makefile.am: use @GLIB_GENMARSHAL@ so we can use uninstalled glib-genmarshal * configure.in: rearrange the library checks to support uninstalled linking * autogen.sh: add support for AUTOGEN_SUBDIR_MODE * atk-uninstalled.pc.in: new file, allows linking to uninstalled ATK in giant GTK tarball 2001-06-07 Havoc Pennington <hp@redhat.com> * tests/Makefile.am: add missing -I flag * gtk/Makefile.am: use @GLIB_MKENUMS@, @GLIB_GENMARSHAL@, etc. * configure.in: use pkg-config to see if GModule is supported; fix to properly turn on included loaders when GModule isn't supported; don't use AC_CHECK_LIB when libs are not installed yet * autogen.sh: add support for AUTOGEN_SUBDIR_MODE * Makefile.am (SUBDIRS): add m4macros subdir * gtk/Makefile.am: $(srcdir)/foo targets must be $(srcdir)/foo in dependencies also.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in64
1 files changed, 38 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index 2d37537cf..9cce11539 100644
--- a/configure.in
+++ b/configure.in
@@ -404,23 +404,11 @@ if test x$with_modules = xno; then
else
AC_MSG_RESULT(yes)
AC_MSG_CHECKING(whether dynamic modules work)
- oLIBS="$LIBS"
- oCFLAGS="$CFLAGS"
- CFLAGS="$GLIB_CFLAGS"
- LIBS="$GLIB_LIBS"
- AC_TRY_RUN([
- #include <glib.h>
- #include <gmodule.h>
- main ()
- {
- if (g_module_supported ())
- exit (0);
- else
- exit (1);
- }
- ], dynworks=true)
- LIBS="$oLIBS"
- CFLAGS="$oCFLAGS"
+ ## for loop is to strip newline
+ tmp=`pkg-config --variable=gmodule_supported gmodule-2.0`
+ for I in $tmp; do
+ dynworks=$I
+ done
fi
dnl Now we check to see if our libtool supports shared lib deps
@@ -525,6 +513,15 @@ AC_MSG_CHECKING(pixbuf loaders to build)
AC_ARG_WITH(included_loaders, [ --with-included-loaders=LOADER1,LOADER2,... Build the specified loaders into gdk-pixbuf (only used if module loading disabled)])
+if $dynworks; then
+ :
+else
+ ## if the option was specified, leave it; otherwise disable included loaders
+ if test x$with_included_loaders = xno; then
+ with_included_loaders=yes
+ fi
+fi
+
all_loaders="png,bmp,wbmp,gif,ico,jpeg,pnm,ras,tiff,xpm"
included_loaders=""
# If no loaders specified, include all
@@ -651,16 +648,21 @@ if test "x$gdktarget" = "xx11"; then
PANGO_PACKAGES="pangox"
have_xft=false
fi
+
AM_CONDITIONAL(HAVE_XFT, $have_xft)
x_libs="`$PKG_CONFIG --libs $PANGO_PACKAGES`"
x_cflags="`$PKG_CONFIG --cflags $PANGO_PACKAGES`"
x_extra_libs=
- # Sanity check for the X11 library
- AC_CHECK_LIB(X11, XOpenDisplay, :,
- AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]),
- $x_libs)
+ if $PKG_CONFIG --uninstalled $PANGO_PACKAGES; then
+ :
+ else
+ # Sanity check for the X11 library
+ AC_CHECK_LIB(X11, XOpenDisplay, :,
+ AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]),
+ $x_libs)
+ fi
if test "x$enable_shm" = "xyes"; then
# Check for the Xext library (needed for XShm extention)
@@ -883,9 +885,13 @@ fi
CFLAGS="$CFLAGS $PANGO_CFLAGS"
-AC_CHECK_LIB(pango, pango_context_new, :, AC_MSG_ERROR([
+if $PKG_CONFIG --uninstalled $PANGO_PACKAGES; then
+ :
+else
+ AC_CHECK_LIB(pango, pango_context_new, :, AC_MSG_ERROR([
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see http://www.pango.org]), $PANGO_LIBS)
+fi
CFLAGS="$saved_cflags"
LDFLAGS="$saved_ldflags"
@@ -919,10 +925,13 @@ else
])
fi
-AC_CHECK_LIB(atk, atk_object_get_type, : , AC_MSG_ERROR([
-*** Cannot link to Accessibility Toolkit. Accessibility Toolkit is required
-*** to build GTK+]), $ATK_LIBS $GLIB_LIBS)
-
+if $PKG_CONFIG --uninstalled $ATK_PACKAGES; then
+ :
+else
+ AC_CHECK_LIB(atk, atk_object_get_type, : , AC_MSG_ERROR([
+ *** Cannot link to Accessibility Toolkit. Accessibility Toolkit is required
+ *** to build GTK+]), $ATK_LIBS $GLIB_LIBS)
+fi
GTK_PACKAGES=atk
GTK_EXTRA_LIBS=
@@ -1091,6 +1100,9 @@ Makefile
gdk-pixbuf-2.0.pc
gdk-2.0.pc
gtk+-2.0.pc
+gdk-pixbuf-2.0-uninstalled.pc
+gdk-2.0-uninstalled.pc
+gtk+-2.0-uninstalled.pc
po/Makefile.in
build/Makefile
build/win32/Makefile