summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Gertzfield <che@src.gnome.org>1998-11-17 21:19:25 +0000
committerBen Gertzfield <che@src.gnome.org>1998-11-17 21:19:25 +0000
commit9b26da82ca4dc1a9d8707d6a581dc0b51f9092fb (patch)
tree351a57944fbaca06b2d1b0a74cba1753e13ff4f8 /debian
parentcb4a61eaa371d17038f88639fd5fc742f51f4c6d (diff)
downloadgdk-pixbuf-9b26da82ca4dc1a9d8707d6a581dc0b51f9092fb.tar.gz
Added Debian CVS build scripts. To build a snapshot Debian release,
simply run, from within the top level of the gtk+ directory: [ben@gilgamesh:~/src/gtk-snap/gtk+]% debian/build 1:16PM This will build a Debian snapshot release, updating debian/changelog, and place the resultant .debs in .. (~/src/gtk-snap/ in this example). The version numbers are automatically updated, and look like: YYYYMMDD.XX where YYYY is the four-digit year (Y10K problem!) and MM is the month (01-12) and DD is the day (01-31). XX is the build number; it starts at 01 and debian/build increments it if you build from CVS more than once in a day. If you're doing more than 99 CVS builds in one day you need your head checked. *NOTE*! The debian/build script I've written does not check in the changes it has made to debian/changelog; that'd be scary and probably generate too many log files all the time. This really doesn't matter *too* much, since debian/changelog is kind of irrelevant with CVS builds. Just know that the scant information that is in there will not be updated via CVS. Also, for obvious reasons, the debian/build script I've written disables PGP signing of the resultant .changes and .dsc file. Since these packages are not going into any archives, this will not be a problem. Of course, all this doesn't mean much to you if you don't have the Debian dpkg-dev tools and debhelper installed, so don't worry if you have no idea what I'm talking about. :)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build62
-rw-r--r--debian/changelog165
-rw-r--r--debian/control68
-rw-r--r--debian/copyright6
-rw-r--r--debian/libgtk-cvs-dev.files9
-rw-r--r--debian/libgtk-cvs-dev.postinst (renamed from debian/libgtk-dev.postinst)2
-rw-r--r--debian/libgtk-cvs-dev.prerm (renamed from debian/libgtk-dev.prerm)0
-rw-r--r--debian/libgtk-cvs-doc.files8
-rw-r--r--debian/libgtk-cvs-doc.postinst (renamed from debian/libgtk-doc.postinst)3
-rw-r--r--debian/libgtk-cvs-doc.prerm (renamed from debian/libgtk-doc.prerm)1
-rwxr-xr-xdebian/rules200
11 files changed, 258 insertions, 266 deletions
diff --git a/debian/build b/debian/build
new file mode 100755
index 000000000..7a70d07bb
--- /dev/null
+++ b/debian/build
@@ -0,0 +1,62 @@
+#!/usr/bin/perl -w
+
+ # Adjust debian/changelog and build a new
+ # Debian package of a CVS archive.
+
+ # Written 17 November 1998 by Ben Gertzfield
+ # <che@debian.org>
+
+ # This work is released under the GNU
+ # General Public License, version 2 or
+ # later.
+
+use strict;
+use diagnostics;
+use File::Copy;
+
+my $maintainer = 'Ben Gertzfield <che@debian.org>';
+
+my @date = localtime;
+
+my $datestr = sprintf("%d%.2d%.2d", $date[5] + 1900, $date[4] + 1, $date[3]);
+my $revision = '01';
+
+open (CHANGELOG, 'debian/changelog') or die "Couldn't open debian/changelog: $!\n";
+
+$_ = <CHANGELOG>;
+chomp;
+
+close CHANGELOG;
+
+my ($package, $last_date, $last_revision) = /^(.*?) \((.*?)\.(.*)?\)/;
+
+if ($last_date eq $datestr) {
+ $revision = sprintf("%.2d", $last_revision + 1);
+}
+
+my $new_version = "$datestr.$revision";
+
+copy('debian/changelog', 'debian/changelog.old') or die "Couldn't copy debian/changelog to debian/changelog.old: $!\n";
+
+open(NEWCHANGELOG, ">debian/changelog") or die "Couldn't open debian/changelog for writing: $!\n";
+
+print NEWCHANGELOG "$package ($new_version) unstable; urgency=low\n\n * CVS snapshot build at " . scalar localtime() . "\n\n -- $maintainer " . `date -R` . "\n";
+
+open(OLDCHANGELOG, "debian/changelog.old") or die "Couldn't open debian/changelog.old: $!\n";
+
+while (<OLDCHANGELOG>) {
+ print NEWCHANGELOG;
+}
+
+close OLDCHANGELOG;
+close NEWCHANGELOG;
+
+unlink('debian/changelog.old') or die "Couldn't unlink debian/changelog.old: $!\n";
+
+open(NEWVERSION, '>debian/version') or die "Couldn't open debian/version for writing: $!\n";
+print NEWVERSION $new_version;
+close NEWVERSION;
+
+system('dpkg-buildpackage -rfakeroot -us -uc');
+unlink 'debian/version' or die "Couldn't unlink debian/version: $!\n";
+
diff --git a/debian/changelog b/debian/changelog
index 8164660b5..65ac25e95 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,167 +1,8 @@
-gtk+ (1:0.99.8-1) unstable; urgency=low
+gtk+-cvs (19981116.01) unstable; urgency=low
- * New upstream version.
- * New file included in libgtk-dev: /usr/share/aclocal/gtk.m4,
- to help autoconf/automake developers use gtk and gtk-config
- more easily.
- * New file included in libgtk-doc: /usr/doc/libgtk-doc/gtk-config.txt
- Please refer to this doc when developing for gtk or compiling
- and running into odd path-related errors.
-
- -- Ben Gertzfield <che@debian.org> Thu, 19 Mar 1998 19:58:53 -0800
+ * First test build from CVS
-gtk+ (1:0.99.7-4) frozen unstable; urgency=low
-
- * Rebuild with native Debian libtool to have libraries properly
- linked with libc and libX et al.
-
- -- Ben Gertzfield <che@debian.org> Tue, 17 Mar 1998 16:05:13 -0800
-
-gtk+ (1:0.99.7-3) frozen unstable; urgency=low
-
- * Accidentally included all the html docs in /usr/doc/libgtk-doc/faq-html;
- moved the tutorial into /usr/doc/libgtk-doc/tutorial-html.
- * Included the Italian Gtk+ Tutorial in
- /usr/doc/libgtk-doc/italian-tutorial-html.
-
- -- Ben Gertzfield <che@debian.org> Mon, 16 Mar 1998 22:39:57 -0800
-
-gtk+ (1:0.99.7-2) unstable; urgency=low
-
- * Upstream source added a /usr/lib/glib/ directory that I didn't
- notice; included this directory in libgtk-dev.
- * Realized that Xinput support was broken because I was doing
- ./configure --enable-xinput=xfree instead of ./configure
- --with-xinput=xfree. Fixed.
-
- -- Ben Gertzfield <che@debian.org> Sun, 15 Mar 1998 19:17:05 -0800
-
-gtk+ (1:0.99.7-1) unstable; urgency=low
-
- * New upstream release -- THIS IS INCOMPATIBLE WITH OLDER RELEASES!
- All Gtk-using packages *will* need patches to work with this Gtk!
- * Upstream release includes 'gtk-config' script to check installed
- version of Gtk; included said script in libgtk-dev in /usr/bin.
-
- -- Ben Gertzfield <che@debian.org> Sun, 15 Mar 1998 11:03:03 -0800
-
-gtk+ (1:0.99.5-2) unstable; urgency=low
-
- * Modified libgtk-doc to Replace: libgtk-dev (<< 1:0.99.4) to
- deal with both packages including the same .info files.
- Fixes bug #19533.
- * Also noticed that libgtk-dev depended on libgtk1 without
- an epoch! Fixed.
-
- -- Ben Gertzfield <che@debian.org> Thu, 12 Mar 1998 13:37:11 -0800
-
-gtk+ (1:0.99.5-1) unstable; urgency=low
-
- * Wow, that was quick, a new upstream version.
-
- -- Ben Gertzfield <che@debian.org> Mon, 9 Mar 1998 22:08:08 -0800
-
-gtk+ (1:0.99.4-3) unstable; urgency=low
-
- * Recompiled with --enable-xinput=xfree to enable Wacom pads
- and other physical input devices.
-
- -- Ben Gertzfield <che@debian.org> Mon, 9 Mar 1998 21:26:07 -0800
-
-gtk+ (1:0.99.4-2) unstable; urgency=MEDIUM
-
- * Ack! The shlibs file makes things depend on libgtk1 (>= 0.99.4)
- rather than (>= 1:0.99.4)! Fixes bug #19134.
-
- -- Ben Gertzfield <che@debian.org> Sat, 7 Mar 1998 23:57:33 -0800
-
-gtk+ (1:0.99.4-1) unstable; urgency=low
-
- * New upstream version.
- * Recompiled with new debhelper to remove du warnings.
- * Upstream source is named gtk+, not libgtk1. Changed source name.
- * Removed --disable-xim in hopes that xim is no longer broken.
- * Removed testgtk at the behest of the Gtk developers until I can
- come up with a better solution, probably related to:
- * the new libgtk-doc package! :) libgtk-doc contains the Gtk FAQ,
- the Gtk Tutorial, and the Gtk info files.
-
- -- Ben Gertzfield <che@debian.org> Tue, 3 Mar 1998 22:23:47 -0800
-
-libgtk1 (1:0.99.3-2) unstable; urgency=low
-
- * Created manpage for testgtk program.
- * Fixed copyright mention to LGPL.gz to be just LGPL.
- * This fixes all known lintian errors.
-
- -- Ben Gertzfield <che@debian.org> Wed, 11 Feb 1998 14:07:17 -0800
-
-libgtk1 (1:0.99.3-1) unstable; urgency=low
-
- * New upstream version.
- * Include the testgtk binary in libgtk-dev.
-
- -- Ben Gertzfield <che@debian.org> Sat, 24 Jan 1998 15:30:09 -0800
-
-libgtk1 (1:0.99.2-2) unstable; urgency=low
-
- * Fixed shlibs file to specify version >=1:0.99.2.
- * Renamed debian/postinst.libgtk1 to debian/postinst, so debhelper
- would actually install it.
-
- -- Ben Gertzfield <che@debian.org> Mon, 5 Jan 1998 12:22:46 -0800
-
-libgtk1 (1:0.99.2-1) unstable; urgency=low
-
- * New upstream version.
-
- -- Ben Gertzfield <che@debian.org> Sun, 4 Jan 1998 00:21:21 -0800
-
-libgtk1 (1:0.99.0-1) unstable; urgency=medium
-
- * New upstream version with new numbering scheme, went to epoch :1
- correspondingly.
- * Hopefully fixed entry-field bug.
- * Converted to use debhelper.
-
- -- Ben Gertzfield <che@debian.org> Mon, 15 Dec 1997 12:02:25 -0800
-
-libgtk1 (971201-1) unstable; urgency=low
-
- * New upstream version.
- * Fixed copyright to say LGPL, not GPL. (bug #14867)
- * Re-added postinst ldconfig call. (bug #14213)
- * Info files should be correct now. (bugs #14773, #15143)
-
- -- Ben Gertzfield <che@debian.org> Mon, 1 Dec 1997 16:41:50 -0800
-
-libgtk1 (971109-1) unstable; urgency=low
-
- * New upstream version.
- * Name is really 'GIMP Tool Kit', not 'General Tool Kit'.
-
- -- Ben Gertzfield <che@debian.org> Mon, 10 Nov 1997 16:15:27 -0800
-
-libgtk1 (970925-3) unstable; urgency=low
-
- * Moved the include files to /usr/include/{gtk,gdk}.
- * Removed postinst/postrm ldconfig calls, fixes old gimp bug #13773.
-
- -- Ben Gertzfield <che@debian.org> Fri, 17 Oct 1997 17:06:10 -0700
-
-libgtk1 (970925-2) unstable; urgency=low
-
- * Added the shlibs file.
- * Removed the postinst/postrm calls to ldconfig, fixes bug #13733.
-
- -- Ben Gertzfield <che@debian.org> Fri, 10 Oct 1997 17:55:39 -0700
-
-libgtk1 (970925-1) unstable; urgency=low
-
- * New upstream version.
- * Split off source tree from gimp's source tree.
-
- -- Ben Gertzfield <che@debian.org> Mon, 29 Sep 1997 13:14:45 -0700
+ -- Ben Gertzfield <che@debian.org> Tue, 17 Nov 1998 12:02:13 -0800
Local variables:
mode: debian-changelog
diff --git a/debian/control b/debian/control
index c34319faa..8c66e1059 100644
--- a/debian/control
+++ b/debian/control
@@ -1,41 +1,79 @@
-Source: gtk+
-Priority: optional
+Source: gtk+-cvs
+Priority: extra
Section: libs
Maintainer: Ben Gertzfield <che@debian.org>
Standards-Version: 2.4.0.0
-Package: libgtk1
+Package: libgtk-cvs-1.1
Architecture: any
Section: libs
Depends: ${shlibs:Depends}
-Description: The GIMP Toolkit set of widgets for X
+Conflicts: libgtk-dev (<< 1:1.0.2), libgtk1.1
+Description: CVS build of the GIMP Toolkit set of widgets for X
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GTK+ LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
The GIMP Toolkit is a freely available set of widgets for X.
GTK is easy to use, and has been implemented in such projects as
The GNU Image Manipulation Program (The GIMP), GNOME, a GNU
desktop set of utilities for X, and gzilla, a GNU web-browser.
+ .
+ This is the unstable 1.1 branch of GTK. It is not intended for use
+ with stable projects!
-Package: libgtk-dev
+Package: libgtk-cvs-dev
Architecture: any
Section: devel
-Depends: libgtk1 (>= 1:0.99.8)
-Suggests: libgtk-doc
-Replaces: libgtk1 (<= 0.99.7)
-Description: Header files and static libraries for the GIMP Toolkit
+Depends: libgtk-cvs-1.1 (=${Source-Version}), libglib-cvs-dev
+Suggests: libgtk-cvs-doc
+Conflicts: libgtk-dev, libgtk1 (<< 1:1.0.4), libgtk1.1-dev
+Description: CVS build of development files for the GIMP Toolkit
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GTK+ LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
This package contains the header files and static libraries for the
GIMP Toolkit set of widgets for X.
.
+ This is the unstable, 1.1 branch of GTK+. This is not intended for
+ use with stable releases of programs!
+ .
Install this package if you wish to develop your own X programs using
- the GIMP Toolkit, or if you wish to compile your own plug-ins for
+ the GIMP Toolkit 1.1, or if you wish to compile your own plug-ins for
The GIMP.
-Package: libgtk-doc
+Package: libgtk-cvs-doc
Architecture: all
-Section: docs
-Replaces: libgtk-dev (<< 1:0.99.4)
-Description: Documentation and example code for the GIMP Toolkit
+Section: doc
+Conflicts: libgtk-dev (<< 1:0.99.4), libgtk-doc, libgtk1.1-doc
+Description: CVS build of documentation for the GIMP Toolkit
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GTK+ LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
This package contains lots of info-files, HTML docs, FAQs, and
other handy documentation about the GIMP Toolkit set of widgets
- for X.
+ for X.
.
+ This package documents the unstable 1.1 release of the GIMP Toolkit.
+ .
Install this package if you want to have lots of info about the
GIMP toolkit when you're programming.
+
+Package: libgtk-cvs-dbg
+Architecture: any
+Section: devel
+Depends: libgtk-cvs-1.1 (= ${Source-Version}), libgtk-cvs-dev (= ${Source-Version})
+Suggests: libgtk-cvs-doc
+Conflicts: libgtk1.1-dbg
+Description: CVS build of debugging files for the GIMP Toolkit
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GTK+ LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
+ This package contains the debugging static libraries for the
+ GIMP Toolkit set of widgets for X.
+ .
+ This is the unstable, 1.1 branch of GTK+. This is not intended for
+ use with stable releases of programs!
+ .
+ Install this package if you wish to debug your own X programs using
+ the GIMP Toolkit 1.1, or if you wish to debug your own plug-ins for
+ The GIMP.
diff --git a/debian/copyright b/debian/copyright
index 70d71c281..719d44183 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,7 +1,7 @@
-This package was debianized by Ben Gertzfield che@imsa.edu on
-Tue, 22 Jul 1997 20:53:20 -0500
+This package was debianized by Ben Gertzfield <che@debian.org> on
+Tue, 17 Nov 1998 12:07:17 -0800
-It was downloaded from ftp.gimp.org.
+It was produced from the CVS repository at cvs.gimp.org.
It may be redistributed under the terms of the GNU LGPL, Version 2 or
later, found on Debian systems in the file /usr/doc/copyright/LGPL.
diff --git a/debian/libgtk-cvs-dev.files b/debian/libgtk-cvs-dev.files
new file mode 100644
index 000000000..7fa1c2fb6
--- /dev/null
+++ b/debian/libgtk-cvs-dev.files
@@ -0,0 +1,9 @@
+usr/lib/libgdk.so
+usr/lib/libgdk.a
+usr/lib/libgtk.so
+usr/lib/libgtk.a
+usr/include/gdk/
+usr/include/gtk/
+usr/bin/gtk-config
+usr/man/man1/gtk-config.1
+usr/share/aclocal/gtk.m4
diff --git a/debian/libgtk-dev.postinst b/debian/libgtk-cvs-dev.postinst
index 0cd5f28c9..c1fc8b91f 100644
--- a/debian/libgtk-dev.postinst
+++ b/debian/libgtk-cvs-dev.postinst
@@ -2,6 +2,4 @@
set -e
-ldconfig
-
#DEBHELPER#
diff --git a/debian/libgtk-dev.prerm b/debian/libgtk-cvs-dev.prerm
index 2772ad0aa..2772ad0aa 100644
--- a/debian/libgtk-dev.prerm
+++ b/debian/libgtk-cvs-dev.prerm
diff --git a/debian/libgtk-cvs-doc.files b/debian/libgtk-cvs-doc.files
new file mode 100644
index 000000000..21b4cdff4
--- /dev/null
+++ b/debian/libgtk-cvs-doc.files
@@ -0,0 +1,8 @@
+usr/info/gdk.info
+usr/info/gtk.info
+usr/info/gtk.info-1
+usr/info/gtk.info-2
+usr/info/gtk.info-3
+usr/info/gtk.info-4
+usr/info/gtk.info-5
+
diff --git a/debian/libgtk-doc.postinst b/debian/libgtk-cvs-doc.postinst
index 685d2d1b6..ac01e5007 100644
--- a/debian/libgtk-doc.postinst
+++ b/debian/libgtk-cvs-doc.postinst
@@ -8,7 +8,4 @@ install-info --quiet --description="The GIMP Toolkit." \
install-info --quiet --description="The GIMP Drawing Kit." \
--section "The GIMP" "The GIMP" /usr/info/gdk.info.gz
-install-info --quiet --description="The GIMP Library." \
- --section "The GIMP" "The GIMP" /usr/info/glib.info.gz
-
#DEBHELPER#
diff --git a/debian/libgtk-doc.prerm b/debian/libgtk-cvs-doc.prerm
index 108d943f8..9c8095673 100644
--- a/debian/libgtk-doc.prerm
+++ b/debian/libgtk-cvs-doc.prerm
@@ -2,7 +2,6 @@
set -e
install-info --quiet --remove gtk
-install-info --quiet --remove glib
install-info --quiet --remove gdk
#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index 58821a606..0f1a23a26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,27 +1,50 @@
#!/usr/bin/make -f
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# debian/rules file for gtk+ Debian package
+# written April 1998 by Ben Gertzfield <che@debian.org
build: build-stamp
build-stamp:
dh_testdir
- # Add here commands to compile the package.
- ./configure --prefix=/usr --with-xinput=xfree
+ ./autogen.sh --prefix=/usr --with-xinput=xfree
$(MAKE)
- cd docs && make -f Makefile.sgml
+ cd docs && make distdocs
cd ..
touch build-stamp
+build-dbg: build-dbg-stamp
+build-dbg-stamp:
+ dh_testdir
+ ./configure --prefix=/usr --with-xinput=xfree --enable-debug=yes
+ $(MAKE)
+ touch build-dbg-stamp
+
clean:
dh_testdir
dh_testroot
- rm -f build-stamp
+ rm -f build-stamp build-dbg-stamp install-stamp install-dbg-stamp
# Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ cd docs
+ -$(MAKE) maintainer-clean
+ cd ..
-$(MAKE) distclean
- -rm docs/*.html
+ find . -name '*.o' -o -name '_libs' -o -name '*.lo' -o -name '*.a' -o -name '.deps' | xargs rm -rf
dh_clean
+clean-dbg:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp build-dbg-stamp install-stamp install-dbg-stamp
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ cd docs
+ -$(MAKE) maintainer-clean
+ cd ..
+ -$(MAKE) distclean
+ find . -name '*.o' -o -name '_libs' -o -name '*.lo' -o -name '*.a' -o -name '.deps' | xargs rm -rf
+ dh_clean -k
+
install: install-stamp
install-stamp: build
dh_testdir
@@ -30,88 +53,105 @@ install-stamp: build
$(MAKE) prefix=`pwd`/debian/tmp/usr install
touch install-stamp
+install-dbg: install-dbg-stamp
+install-dbg-stamp: build-dbg
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ $(MAKE) prefix=`pwd`/debian/libgtk-cvs-dbg/usr install
+ touch install-dbg-stamp
+
# Build architecture-independent files here.
-binary-indep: build install libgtk-doc
+binary-indep: build install libgtk-cvs-doc
# We have nothing to do by default.
# Build architecture-dependent files here.
-binary-arch: build install libgtk-dev libgtk1
+binary-arch: build install libgtk-cvs-dev libgtk-cvs-1.1 libgtk-cvs-dbg
-libgtk1: build
- dh_testdir -plibgtk1
- dh_testroot -plibgtk1
-# dh_clean -plibgtk1
- dh_installdirs -plibgtk1
+libgtk-cvs-1.1: build
+ dh_testdir -plibgtk-cvs-1.1
+ dh_testroot -plibgtk-cvs-1.1
+ dh_installdirs -plibgtk-cvs-1.1
# Add here commands to install the files into debian/tmp
- rm -rf debian/tmp/usr/bin debian/tmp/usr/include debian/tmp/usr/info debian/tmp/usr/lib/glib debian/tmp/usr/share
-# dh_movefiles -plibgtk1
-# $(MAKE) prefix=`pwd`/debian/tmp/usr install
-# rmdir debian/tmp/usr/bin
-# rm debian/tmp/usr/lib/*.{so,la,a}
-# rm -rf debian/tmp/usr/{include,info}
- dh_installdocs -plibgtk1
- dh_installchangelogs -plibgtk1
- dh_strip -plibgtk1
- dh_compress -plibgtk1
- dh_fixperms -plibgtk1
- dh_installdeb -plibgtk1
- dh_shlibdeps -plibgtk1
- dh_gencontrol -plibgtk1
- dh_makeshlibs -plibgtk1 -V 'libgtk1 (>= 1:0.99.7)'
-# echo "libglib 1 libgtk1 (>=0.99.4)" >> debian/tmp/DEBIAN/shlibs
-# echo "libgtk 1 libgtk1 (>=0.99.4)" >> debian/tmp/DEBIAN/shlibs
-# echo "libgdk 1 libgtk1 (>=0.99.4)" >> debian/tmp/DEBIAN/shlibs
- dh_md5sums -plibgtk1
- dh_builddeb -plibgtk1
-
-libgtk-dev: build
- dh_testdir -plibgtk-dev
- dh_testroot -plibgtk-dev
- dh_clean -plibgtk-dev -k
- dh_installdirs -plibgtk-dev
+ rm -rf debian/tmp/usr/bin debian/tmp/usr/include debian/tmp/usr/info debian/tmp/usr/lib/glib debian/tmp/usr/share/aclocal debian/tmp/usr/man debian/tmp/usr/lib/*.la
+ dh_installdocs -plibgtk-cvs-1.1
+ dh_installchangelogs -plibgtk-cvs-1.1
+ dh_strip -plibgtk-cvs-1.1
+ dh_compress -plibgtk-cvs-1.1
+ dh_fixperms -plibgtk-cvs-1.1
+ dh_installdeb -plibgtk-cvs-1.1
+ dh_shlibdeps -plibgtk-cvs-1.1
+ dh_gencontrol -plibgtk-cvs-1.1
+ dh_makeshlibs -plibgtk-cvs-1.1 -V'libgtk-cvs-1.1 (='`cat debian/version`')'
+ dh_md5sums -plibgtk-cvs-1.1
+ dh_builddeb -plibgtk-cvs-1.1
+
+libgtk-cvs-dev: build
+ dh_testdir -plibgtk-cvs-dev
+ dh_testroot -plibgtk-cvs-dev
+ dh_clean -plibgtk-cvs-dev -k
+ dh_installdirs -plibgtk-cvs-dev
# Add here commands to install the files into debian/tmp
- dh_movefiles -plibgtk-dev
+ dh_movefiles -plibgtk-cvs-dev
cp gtk-config debian/tmp/usr/bin
-# $(MAKE) prefix=`pwd`/debian/libgtk-dev/usr install
-# find debian/libgtk-dev/usr/lib \( -type f -or -type l \) -and ! \( -name \*.so -or -name \*.a \) | xargs rm
-# cp gtk/.libs/testgtk debian/libgtk-dev/usr/bin
-# cp debian/testgtk.1 debian/libgtk-dev/usr/man/man1
- dh_installdocs -plibgtk-dev
- dh_installchangelogs -plibgtk-dev
- dh_strip -plibgtk-dev
- dh_compress -plibgtk-dev
- dh_fixperms -plibgtk-dev
- dh_installdeb -plibgtk-dev
- dh_shlibdeps -plibgtk-dev
- dh_gencontrol -plibgtk-dev
- dh_makeshlibs -plibgtk-dev
- dh_md5sums -plibgtk-dev
- dh_builddeb -plibgtk-dev
-
-libgtk-doc:
- dh_testdir -plibgtk-doc
- dh_testroot -plibgtk-doc
- dh_clean -plibgtk-doc -k
- dh_installdirs -plibgtk-doc usr/doc/libgtk-doc/faq-html \
- usr/doc/libgtk-doc/tutorial-html usr/doc/libgtk-doc/italian-tutorial-html
- # Add here commands to install the files into debian/tmp
- dh_movefiles -plibgtk-doc
- cp docs/gtkfaq*.html debian/libgtk-doc/usr/doc/libgtk-doc/faq-html
- cp docs/gtk_tut-*.html debian/libgtk-doc/usr/doc/libgtk-doc/tutorial-html
- cp docs/gtk_tut.html debian/libgtk-doc/usr/doc/libgtk-doc/tutorial-html
- cp docs/gtk_tut_it*.html debian/libgtk-doc/usr/doc/libgtk-doc/italian-tutorial-html
- dh_installdocs -plibgtk-doc docs/{debugging,developers,styles,text_widget,widget_system,gtk-config}.txt ChangeLog TODO NEWS
- dh_installchangelogs -plibgtk-doc
- dh_strip -plibgtk-doc
- dh_compress -plibgtk-doc
- dh_fixperms -plibgtk-doc
- dh_installdeb -plibgtk-doc
- dh_shlibdeps -plibgtk-doc
- dh_gencontrol -plibgtk-doc
- dh_makeshlibs -plibgtk-doc
- dh_md5sums -plibgtk-doc
- dh_builddeb -plibgtk-doc
+ dh_installdocs -plibgtk-cvs-dev
+ dh_installchangelogs -plibgtk-cvs-dev
+ dh_strip -plibgtk-cvs-dev
+ dh_compress -plibgtk-cvs-dev
+ dh_fixperms -plibgtk-cvs-dev
+ dh_installdeb -plibgtk-cvs-dev
+ dh_shlibdeps -plibgtk-cvs-dev
+ dh_gencontrol -plibgtk-cvs-dev
+ dh_md5sums -plibgtk-cvs-dev
+ dh_builddeb -plibgtk-cvs-dev
+
+libgtk-cvs-doc:
+ dh_testdir -plibgtk-cvs-doc
+ dh_testroot -plibgtk-cvs-doc
+ dh_clean -plibgtk-cvs-doc -k
+ dh_installdirs -plibgtk-cvs-doc usr/doc/libgtk-cvs-doc/faq-html \
+ usr/doc/libgtk-cvs-doc/tutorial-html usr/doc/libgtk-cvs-doc/italian-tutorial-html usr/doc/libgtk-cvs-doc/french-tutorial-html usr/doc/libgtk-cvs-doc/gdk-html
+ dh_movefiles -plibgtk-cvs-doc
+ cp docs/html/gtkfaq*.html debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/faq-html
+ cp docs/html/gtk_tut-*.html debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/tutorial-html
+ cp docs/html/*.gif debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/tutorial-html
+ cp docs/html/gtk_tut.html debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/tutorial-html
+ cp docs/html/gtk_tut_it*.html debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/italian-tutorial-html
+ cp docs/html/*.gif debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/italian-tutorial-html
+ cp docs/html/gtk_tut_fr*.html debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/french-tutorial-html
+ cp docs/html/*.gif debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/french-tutorial-html
+ cp docs/html/gdk* debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/gdk-html
+ cp docs/text/*.txt debian/libgtk-cvs-doc/usr/doc/libgtk-cvs-doc/
+
+ dh_installdocs -plibgtk-cvs-doc docs/{debugging,developers,styles,text_widget,widget_system,gtk-config,refcounting}.txt TODO NEWS
+ dh_installchangelogs -plibgtk-cvs-doc
+ dh_strip -plibgtk-cvs-doc
+ dh_compress -plibgtk-cvs-doc
+ dh_fixperms -plibgtk-cvs-doc
+ dh_installdeb -plibgtk-cvs-doc
+ dh_shlibdeps -plibgtk-cvs-doc
+ dh_gencontrol -plibgtk-cvs-doc
+ dh_md5sums -plibgtk-cvs-doc
+ dh_builddeb -plibgtk-cvs-doc
+libgtk-cvs-dbg: clean-dbg install-dbg
+ dh_testdir -plibgtk-cvs-dbg
+ dh_testroot -plibgtk-cvs-dbg
+ dh_installdirs -plibgtk-cvs-dbg
+ # Add here commands to install the files into debian/libgtk-cvs-dbg
+ rm -rf debian/libgtk-cvs-dbg/usr/bin debian/libgtk-cvs-dbg/usr/include debian/libgtk-cvs-dbg/usr/info debian/libgtk-cvs-dbg/usr/lib/glib debian/libgtk-cvs-dbg/usr/man debian/libgtk-cvs-dbg/usr/share debian/libgtk-cvs-dbg/usr/lib/*.{la,so*}
+ for file in `find debian/libgtk-cvs-dbg/usr/lib -name '*.a'` ; do \
+ mv $$file debian/libgtk-cvs-dbg/usr/lib/`basename $$file .a`_g.a; \
+ done
+ dh_installdocs -plibgtk-cvs-dbg
+ dh_installchangelogs -plibgtk-cvs-dbg
+ dh_compress -plibgtk-cvs-dbg
+ dh_fixperms -plibgtk-cvs-dbg
+ dh_installdeb -plibgtk-cvs-dbg
+ dh_shlibdeps -plibgtk-cvs-dbg
+ dh_gencontrol -plibgtk-cvs-dbg
+ dh_md5sums -plibgtk-cvs-dbg
+ dh_builddeb -plibgtk-cvs-dbg
source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false