summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2008-08-03 23:47:10 +0000
committerTor Lillqvist <tml@src.gnome.org>2008-08-03 23:47:10 +0000
commit71d9f3d45bfed728872c961473b24022a77af63d (patch)
treeecc34b00fc9ee3a3f65f4110c58ae361d84f6548 /gdk/Makefile.am
parent963ee0de5e9cce3e51d810c8ac7219aa44daaa44 (diff)
downloadgdk-pixbuf-71d9f3d45bfed728872c961473b24022a77af63d.tar.gz
Set LIB_EXE_MACHINE_FLAG to either X86 or X64 on Windows. AC_SUBST it.
2008-08-04 Tor Lillqvist <tml@novell.com> * configure.in: Set LIB_EXE_MACHINE_FLAG to either X86 or X64 on Windows. AC_SUBST it. * gdk/Makefile.am * gtk/Makefile.am: Pass appropriate -machine flag to lib.exe. svn path=/trunk/; revision=20957
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index e319e3bd1..e4940cf49 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -194,7 +194,7 @@ if MS_LIB_AVAILABLE
noinst_DATA = gdk-win32-$(GTK_API_VERSION).lib
gdk-win32-$(GTK_API_VERSION).lib: libgdk-win32-$(GTK_API_VERSION).la gdk.def
- lib -name:libgdk-win32-$(GTK_API_VERSION)-@LT_CURRENT_MINUS_AGE@.dll -def:gdk.def -out:$@
+ lib -machine:@LIB_EXE_MACHINE_FLAG@ -name:libgdk-win32-$(GTK_API_VERSION)-@LT_CURRENT_MINUS_AGE@.dll -def:gdk.def -out:$@
install-ms-lib:
$(INSTALL) gdk-win32-$(GTK_API_VERSION).lib $(DESTDIR)$(libdir)