summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@src.gnome.org>1998-12-16 06:05:46 +0000
committerTim Janik <timj@src.gnome.org>1998-12-16 06:05:46 +0000
commit62347c40d97c958a30729986adfde54489102afe (patch)
treedbcb728261bd7f173c40f30581164cc8930da704 /gdk/Makefile.am
parent017dfc9e4ee30ef271b5392a5f45d37ab0ad2e87 (diff)
downloadgdk-pixbuf-62347c40d97c958a30729986adfde54489102afe.tar.gz
urg, fixups
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 543eccb4a..19dc32531 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -59,9 +59,18 @@ gdkinclude_HEADERS = \
gdktypes.h \
gdkx.h
+LDADDS = \
+ @x_ldflags@ \
+ @x_libs@ \
+ @GLIB_LIBS@ \
+ -lm
+
libgdk_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) \
- @x_ldflags@ @x_libs@
+ @GLIB_LIBS@ \
+ @x_ldflags@ \
+ @x_libs@ \
+ -lm
EXTRA_PROGRAMS = gxid
@@ -69,10 +78,7 @@ bin_PROGRAMS = @xinput_progs@
gxid_SOURCES = gxid.c
-gxid_LDADD = \
- @x_ldflags@ \
- @x_libs@ \
- -lm
+gxid_LDADD = $(LDADDS)
X-derived-headers:
sed -e 's/^#define[ ]*XC\([^ ]*\)[ ]*\([^ ]*\)[ ]*.*$$/GDK\1 = \2,/' \