summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-03-02 23:29:02 +0000
committerOwen Taylor <otaylor@src.gnome.org>2002-03-02 23:29:02 +0000
commit15f8a55fbac4ca6c79654fbd85e934cae90cba48 (patch)
treef074cbc30e7bd0cc8478011eb9192ce53a6ed6f2 /gdk/Makefile.am
parent93d74e2574f51386016b511054ef24130b07c89d (diff)
downloadgdk-pixbuf-15f8a55fbac4ca6c79654fbd85e934cae90cba48.tar.gz
Add a --enable-explicit-deps option to control whether dependency
Fri Mar 1 00:46:49 2002 Owen Taylor <otaylor@redhat.com> * configure.in: Add a --enable-explicit-deps option to control whether dependency libraries are written into .la files and .pc files. Default is auto: if static libraries are off and shlib dependencies are found, don't write deps. * gdk/Makefile.am gtk/Makefile.am sanitize-la.sh: Shell script used to strip dependencies out of .la files. * Makefile.am: Add a slightly modified distcheck rule that passes --enable-gtk-doc to the configure inside. (So that 'make dist' succeeds inside.) * configure.in: If pango was compiled with --disable-explicit-deps, then repeat the checks for X and freetype ourselves so we don't depend on linking to libraries that pango doesn't reveal in the link line. Add some more paranoia for whether what we detect ourselves matches what Pango backends we found.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 3cdb3d8ed..3accc9fd4 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -172,7 +172,16 @@ EXTRA_HEADERS =
#
configexecincludedir = $(libdir)/gtk-2.0/include
#configexecinclude_DATA = gdkconfig.h
-install-exec-local: gdkconfig.h
+
+if DISABLE_EXPLICIT_DEPS
+sanitize-la:
+ $(SHELL) $(top_srcdir)/sanitize-la.sh $(DESTDIR)$(libdir)/$(gdktargetlib)
+else
+sanitize-la:
+ @true
+endif
+
+install-exec-local: gdkconfig.h sanitize-la
$(mkinstalldirs) $(DESTDIR)$(configexecincludedir)
file=$(DESTDIR)$(configexecincludedir)/gdkconfig.h; \
if test -r $$file && cmp -s gdkconfig.h $$file; then :; \