summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2004-12-03 04:05:10 +0000
committerTor Lillqvist <tml@src.gnome.org>2004-12-03 04:05:10 +0000
commit5d90733686c2da2660367b45ed1f0eed59995656 (patch)
treeac85493b1446d30a240be6d5b15caa63a39884dc /gdk/Makefile.am
parentbe60805ef6f41ddbd69f1b3b4ac1052d7b05ca3b (diff)
downloadgdk-pixbuf-5d90733686c2da2660367b45ed1f0eed59995656.tar.gz
gdk-pixbuf/Makefile.am (gdk_pixbuf.def) gdk/Makefile.am (gdk.def) Work
2004-12-03 Tor Lillqvist <tml@iki.fi> * gdk-pixbuf/Makefile.am (gdk_pixbuf.def) * gdk/Makefile.am (gdk.def) * gtk/Makefile.am (gtk.def): Work around gcc misfeature. At least gcc 3.3.1 doesn't like to do -E on files that it thinks aren't source files. Use redirection and '-' instead.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 8e69a3aba..acd669f20 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -177,7 +177,7 @@ uninstall-ms-lib:
endif
gdk.def: gdk.symbols
- (echo -e EXPORTS; $(CPP) -P -DGDK_WINDOWING_WIN32 -DINCLUDE_VARIABLES $(srcdir)/gdk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > gdk.def
+ (echo -e EXPORTS; $(CPP) -P -DGDK_WINDOWING_WIN32 -DINCLUDE_VARIABLES - <$(srcdir)/gdk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > gdk.def
gdkalias.h: gdk.symbols
$(PERL) $(srcdir)/makegdkalias.pl < $(srcdir)/gdk.symbols > gdkalias.h