summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2003-01-12 04:44:23 +0000
committerTor Lillqvist <tml@src.gnome.org>2003-01-12 04:44:23 +0000
commit4a3c812b7d65144e7b56c83efcad415dfe9ba3ac (patch)
tree9bd305c50c8874c8336f56f5d3152c6134f7e6c5 /gdk/Makefile.am
parent4b05e4b4a89f713900b8c710520c2fdf7885f47c (diff)
downloadgdk-pixbuf-4a3c812b7d65144e7b56c83efcad415dfe9ba3ac.tar.gz
Merge from stable:
2003-01-12 Tor Lillqvist <tml@iki.fi> Merge from stable: * gtk/gtkmain.c: Move inclusion of config.h and gtkintl.h earlier, as gtkprivate.h redefines GTK_LOCALEDIR on Win32, for run-time lookup. * gdk/Makefile.am (libgdk_win32_2_0_la_DEPENDENCIES): Depend on gdk.def. * gdk/gdk.def * gtk/gtk.def: Add some missing entries. Thanks to Kenichi SUTO. * gtk-zip.sh.in (DEVZIP): Add bin/{gtk-query-immodules-2.0, gtk-demo}.exe and share/gtk-2.0. * gdk/win32/gdkwindow-win32.c (gdk_window_set_skip_taskbar_hint): Implement by setting or clearing the WS_EX_TOOLWINDOW extended window style. (gdk_window_set_type_hint): Add all cases to the switch (not all do anything, though). Handle GDK_WINDOW_TYPE_HINT_TOOLBAR by calling gdk_window_set_skip_taskbar_hint(). This means that GTK won't know that the skip_taskbar hint is on for the window, is this bad?
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index f33a518c5..a91b4c8eb 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -179,6 +179,7 @@ libgdk_linux_fb_2_0_la_LIBADD = linux-fb/libgdk-linux-fb.la @GDK_DEP_LIBS@
libgdk_win32_2_0_la_LIBADD = \
win32/libgdk-win32.la $(wintab_lib) $(ie55uuid_lib) \
@GDK_DEP_LIBS@
+libgdk_win32_2_0_la_DEPENDENCIES = gdk.def
lib_LTLIBRARIES = $(gdktargetlib)