summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2005-08-29 17:47:10 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2005-08-29 17:47:10 +0000
commit60182d34db6ecae47df16deed5be77c9209ef089 (patch)
treed6decba053eebbd21d95f90b1646e44166fd6a01 /gtk/Makefile.am
parent1299979c956074e5add50ceca181398afb6669db (diff)
downloadgdk-pixbuf-60182d34db6ecae47df16deed5be77c9209ef089.tar.gz
Add a cross-platform "tray icon" API, by porting EggStatusIcon/EggTrayIcon
2005-08-29 Matthias Clasen <mclasen@redhat.com> Add a cross-platform "tray icon" API, by porting EggStatusIcon/EggTrayIcon (#105101) * gtk/gtkstatusicon.h: A GtkStatusIcon is an object which displays an icon in a notification area. * gtk/gtkstatusicon-x11.c: GtkStatusIcon implementation for X11, using GtkTrayIcon. * gtk/gtktrayicon.h: * gtk/gtktrayicon.c: An implementation of the freedesktop.org system tray specification, not public API. * gtk/gtk.symbols: Add new exported functions. * gtk/gtk.h: Include gtkstatusicon.h. * gtk/Makefile.am: Add new files. * tests/Makefile.am: * tests/teststatusicon.c: Test for GtkStatusIcon.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 5f9433081..4ea8eda68 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -239,6 +239,7 @@ gtk_public_h_sources = \
gtksocket.h \
gtkspinbutton.h \
gtkstatusbar.h \
+ gtkstatusicon.h \
gtkstock.h \
gtkstyle.h \
gtktable.h \
@@ -535,8 +536,13 @@ gtk_c_sources += gtkfilesystemwin32.c
endif
if USE_X11
-gtk_private_h_sources += gtkxembed.h
-gtk_c_sources += gtkplug-x11.c gtksocket-x11.c gtkxembed.c
+gtk_private_h_sources += gtkxembed.h gtktrayicon.h
+gtk_c_sources += \
+ gtkplug-x11.c \
+ gtksocket-x11.c \
+ gtkxembed.c \
+ gtktrayicon.c \
+ gtkstatusicon-x11.c
else
if USE_WIN32
gtk_private_h_sources += gtkwin32embed.h