summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorManish Singh <yosh@src.gnome.org>1998-12-01 10:42:01 +0000
committerManish Singh <yosh@src.gnome.org>1998-12-01 10:42:01 +0000
commit70784023413b1e6fb748ad5e51d8d311ed651f0f (patch)
tree547b1f5f25579f57daf10d8c891031cccddcdba1 /gtk/Makefile.am
parent6047ed3ebd1c903e43c106f596b29a7eb35ba605 (diff)
downloadgdk-pixbuf-70784023413b1e6fb748ad5e51d8d311ed651f0f.tar.gz
configure.in gdk/Makefile.am Put -DFOO stuff into Makefile.am INCLUDES.
* configure.in * gdk/Makefile.am * gtk/Makefile.am: Put -DFOO stuff into Makefile.am INCLUDES. Separate vars for each, for granularity. -Yosh
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 056136441..4643c5610 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -340,10 +340,16 @@ EXTRA_DIST = \
circles.xbm
INCLUDES = \
- -DG_LOG_DOMAIN=\"Gtk\" \
- -DGTK_EXE_PREFIX=\"$(exec_prefix)\" \
- -DGTK_DATA_PREFIX=\"$(prefix)\" \
- -I$(top_srcdir) @GLIB_CFLAGS@ @x_cflags@
+ -DG_LOG_DOMAIN=\"Gtk\" \
+ -DGTK_EXE_PREFIX=\"$(exec_prefix)\" \
+ -DGTK_DATA_PREFIX=\"$(prefix)\" \
+ -I$(top_srcdir) \
+ @GTK_DEBUG_FLAGS@ \
+ @GTK_XIM_FLAGS@ \
+ @GTK_LOCALE_FLAGS@ \
+ @GTK_THREAD_FLAGS@ \
+ @GLIB_CFLAGS@ \
+ @x_cflags@
noinst_PROGRAMS = testgtk testinput testselection testthreads testrgb testdnd simple