summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2004-09-01 20:30:24 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2004-09-01 20:30:24 +0000
commit8189921f446a585398d8df69d589b6003ccbffdb (patch)
tree92dcb32a0d29888b23f82d91b61615a21b2b5317 /gtk/Makefile.am
parent0ac4f2837a6e8d57f79846f4cef65658122264b5 (diff)
downloadgdk-pixbuf-8189921f446a585398d8df69d589b6003ccbffdb.tar.gz
Make it possible to specify additional modules to load via a setting.
2004-09-01 Matthias Clasen <mclasen@redhat.com> Make it possible to specify additional modules to load via a setting. (#117236, Alex Graveley) * gtk/gtkmodules.h: * gtk/gtkmodules.c: New files which contain the module handling code which was previously in gtkmain.[hc]. Additionally, the code now looks for the gtk-modules setting, which can specify additional modules to load. * gtk/gtkmain.c: * gtk/gtkmain.h: Remove all the module handling code. * gtk/gtkdebug.h: Add a debug flag for modules. * gtk/gtk.h: Include gtkmodules.h * gtk/Makefile.am (gtk_public_h_sources): Add gtkmodules.h (gtk_c_sources): Add gtkmodules.c * gtk/gtksettings.c: Add the gtk-modules setting. * gdk/x11/gdkevents-x11.c: Add the Gtk/Modules XSetting.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index dce232111..4ebb8c993 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -203,6 +203,7 @@ gtk_public_h_sources = \
gtkmenushell.h \
gtkmessagedialog.h \
gtkmisc.h \
+ gtkmodules.h \
gtknotebook.h \
gtkobject.h \
gtkoldeditable.h \
@@ -422,6 +423,7 @@ gtk_c_sources = \
gtkmenushell.c \
gtkmessagedialog.c \
gtkmisc.c \
+ gtkmodules.c \
gtknotebook.c \
gtkobject.c \
gtkoldeditable.c \