summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2005-03-20 07:01:23 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2005-03-20 07:01:23 +0000
commitcca8dd63475ab582d8592039f1f69d7f22a3b928 (patch)
treef800dcc62e1ab8a0010e774a05e669b14c3ff5e1 /gtk/Makefile.am
parentb39b0bfc0471258285169113bc176320b0b5ae71 (diff)
downloadgdk-pixbuf-cca8dd63475ab582d8592039f1f69d7f22a3b928.tar.gz
Make PLT-reduction work with gcc4, and don't include everything in
2005-03-20 Matthias Clasen <mclasen@redhat.com> Make PLT-reduction work with gcc4, and don't include everything in gdkalias.h: * gtk/grk.symbols: Group symbols by header and source file. * gtk/makegtkalias.pl: Protect definitions by the same preprocessor symbols used to guard the headers. Move the alias declarations to a separate file which is produced when calling makegtkalias.pl -def * gdk/Makefile.am (gtkaliasdef.c): Add a rule to generate this file. * gtk/*.c: Include gtkalias.h after the other headers, include gtkaliasdef.c at the bottom. * gtk/*.h: Small cleanups.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 4904894ac..a509c247a 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -75,10 +75,12 @@ uninstall-ms-lib:
endif
gtk.def: gtk.symbols
- (echo -e EXPORTS; $(CPP) -P -DINCLUDE_VARIABLES -DG_OS_WIN32 - <$(srcdir)/gtk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > gtk.def
+ (echo -e EXPORTS; $(CPP) -P -DINCLUDE_VARIABLES -DG_OS_WIN32 -DALL_FILES - <$(srcdir)/gtk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > gtk.def
gtkalias.h: gtk.symbols
$(PERL) $(srcdir)/makegtkalias.pl < $(srcdir)/gtk.symbols > gtkalias.h
+gtkaliasdef.c: gtk.symbols
+ $(PERL) $(srcdir)/makegtkalias.pl -def < $(srcdir)/gtk.symbols > gtkaliasdef.c
if OS_LINUX
TESTS = abicheck.sh
@@ -553,6 +555,7 @@ gtk_built_private_headers = \
gtkmarshalers.h
gtk_built_sources = \
+ gtkaliasdef.c \
gtktypebuiltins.c \
gtkmarshalers.c \
gtkmarshalers.h \
@@ -636,7 +639,8 @@ stamp-gtktypebuiltins.h: @REBUILD@ $(gtk_public_h_sources) Makefile
&& echo timestamp > $(@F)
gtktypebuiltins.c: @REBUILD@ $(gtk_public_h_sources) Makefile
( cd $(srcdir) && glib-mkenums \
- --fhead "#undef GTK_DISABLE_DEPRECATED\n#define GTK_ENABLE_BROKEN\n#include \"gtkalias.h\"\n#include \"gtk.h\"\n#include \"gtkprivate.h\"" \
+ --fhead "#undef GTK_DISABLE_DEPRECATED\n#define GTK_ENABLE_BROKEN\n#include \"gtk.h\"\n#include \"gtkprivate.h\"\n#include \"gtkalias.h\"\n" \
+ --ftail "#define __GTK_TYPE_BUILTINS_C__\n#include \"gtkaliasdef.c\"\n" \
--fprod "\n/* enumerations from \"@filename@\" */" \
--vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \
--vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \