summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1999-02-24 16:29:47 +0000
committerTim Janik <timj@src.gnome.org>1999-02-24 16:29:47 +0000
commitc4fe78345e11dfd2ed909500cdc6000682d96304 (patch)
treea9db551c00b2a2ef3169ae3a6f532a6217e80955 /gtk/Makefile.am
parent082c0c8975001303cd3a50f2160766c77fc7710b (diff)
downloadgdk-pixbuf-c4fe78345e11dfd2ed909500cdc6000682d96304.tar.gz
warn about &widget->requisition, even for toplevels.
Wed Feb 24 11:19:12 1999 Tim Janik <timj@gtk.org> * gtk/gtkwidget.c (gtk_widget_size_request): warn about &widget->requisition, even for toplevels. * gtk/gtkwindow.c (gtk_window_move_resize): request size into an automatic variable and check if our size has changed. when we decide to reallocate everything, we need to resize our own GdkWindow as well. * gtk/gtkmain.c: * gtk/gtkobject.c: hack time, make --gtk-debug=objects work even after gtk_type_init(), this is to "fix" gnome's arg parsing oddities. * gtk/gtktypeutils.h: don't segfault in GTK_CHECK_CLASS_TYPE and GTK_CHECK_TYPE upon NULL pointers. * gtk/gtklayout.c: removed bogus prototypes of gtk_layout_gravity_works, gtk_layout_set_static_gravity, gtk_layout_add_child_cb and gtk_layout_remove_child_cb to shut up compiler. * gtk/Makefile.am: added an empty rule gtkrc: : so make doesn't try to "update" gtkrc from gtkrc.c.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index a17e75d54..e81ee1486 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -312,8 +312,11 @@ libgtk_la_LDFLAGS = \
# $(top_builddir)/gdk/libgdk.la
gtkconfdir = $(sysconfdir)/gtk
-gtkconf_DATA = gtkrc.ja gtkrc.ko gtkrc.ru
+gtkconf_DATA = gtkrc gtkrc.ja gtkrc.ko gtkrc.ru
+gtkrc:
+ :
+
# We create a dummy theme for the default GTK+ theme
install-data-local: