summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-08-04 15:33:06 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-08-17 15:14:54 +0800
commitc1a8ca5c6536246cb094a1d1eda149a3740e5521 (patch)
tree03235d2a4bc144ff582b9f01eac013659f9fa18a /meson.build
parent480e4834115a10b3f81615527803c5601ff18c77 (diff)
downloadgdk-pixbuf-c1a8ca5c6536246cb094a1d1eda149a3740e5521.tar.gz
build: Build the .rc file on Windows
Like the autotools and Visual Studio builds, include the .rc file in the main GDK-Pixbuf DLL so that people can determine its version info more easily. Determine current - age as we did in the autotools builds. https://bugzilla.gnome.org/show_bug.cgi?id=785767
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0db2c02db..5f64f2877 100644
--- a/meson.build
+++ b/meson.build
@@ -40,6 +40,8 @@ soversion = 0
current = gdk_pixbuf_binary_age - gdk_pixbuf_interface_age
revision = gdk_pixbuf_interface_age
libversion = '@0@.@1@.@2@'.format(soversion, current, revision)
+age = gdk_pixbuf_binary_age - gdk_pixbuf_interface_age
+current_minus_age = current - age
# Paths
gdk_pixbuf_prefix = get_option('prefix')