summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2015-09-21 00:20:42 +0200
committerBenjamin Otte <otte@redhat.com>2015-10-13 02:56:47 +0200
commit72498462faaccce5de73c61dd640aeb796e10eba (patch)
treeb2096044a881cd4cfe08faa66b0205823ceeb842 /tests/Makefile.am
parentb5577265295a7a631b7467a5d6fe7091a92f4ea8 (diff)
downloadgdk-pixbuf-72498462faaccce5de73c61dd640aeb796e10eba.tar.gz
tests: Add TGA test
Add a bunch of TGA files and a test that loads the image byte by byte and copies only the parts given via the area-updated signal of the loader and then checks the resulting image is correct.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c12218814..32a0a9a4e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -35,6 +35,7 @@ test_programs = \
pixbuf-resource \
pixbuf-scale \
pixbuf-short-gif-write \
+ pixbuf-slow-load \
pixbuf-save \
pixbuf-readonly-to-mutable \
pixbuf-composite \
@@ -57,7 +58,8 @@ dist_installed_test_data = \
cve-2015-4491.bmp \
large.png \
large.jpg \
- $(wildcard $(srcdir)/test-images/*)
+ $(wildcard $(srcdir)/test-images/*) \
+ $(wildcard $(srcdir)/test-images/tga/*)
cve_2015_4491_SOURCES = \
cve-2015-4491.c \
@@ -109,6 +111,12 @@ pixbuf_save_SOURCES = \
test-common.h \
$(NULL)
+pixbuf_slow_load_SOURCES = \
+ pixbuf-slow-load.c \
+ test-common.c \
+ test-common.h \
+ $(NULL)
+
pixbuf_jpeg_SOURCES = \
pixbuf-jpeg.c \
test-common.c \