summaryrefslogtreecommitdiff
path: root/build/win32/vs10/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/win32/vs10/Makefile.am')
-rw-r--r--build/win32/vs10/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/build/win32/vs10/Makefile.am b/build/win32/vs10/Makefile.am
index ac21eb3ca..dd891edb9 100644
--- a/build/win32/vs10/Makefile.am
+++ b/build/win32/vs10/Makefile.am
@@ -1,13 +1,16 @@
+GENERATED_ITEMS = \
+ gdk-pixbuf.vcxproj \
+ gdk-pixbuf.vcxproj.filters \
+ gdk-pixbuf-install.props
+
EXTRA_DIST = \
README.txt \
gdk-pixbuf.sln \
gdk-pixbuf-version-paths.props \
gdk-pixbuf-build-defines.props \
gdk-pixbuf-gen-srcs.props \
- gdk-pixbuf-install.props \
- gdk-pixbuf.vcxproj \
+ gdk-pixbuf-install.propsin \
gdk-pixbuf.vcxprojin \
- gdk-pixbuf.vcxproj.filters \
gdk-pixbuf.vcxproj.filtersin \
gdk-pixbuf-csource.vcxproj \
gdk-pixbuf-csource.vcxproj.filters \
@@ -15,6 +18,13 @@ EXTRA_DIST = \
gdk-pixbuf-query-loaders.vcxproj.filters \
gdk-pixbuf-pixdata.vcxproj \
gdk-pixbuf-pixdata.vcxproj.filters \
- gdk-pixbuf-install.vcxproj
+ gdk-pixbuf-install.vcxproj \
+ $(GENERATED_ITEMS)
+
+gdk-pixbuf-install.props: $(top_srcdir)/build/win32/vs10/gdk-pixbuf-install.propsin gdk-pixbuf.vs10.headers
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs10/gdk-pixbuf-install.propsin >$@
+ rm gdk-pixbuf.vs10.headers
+
+DISTCLEANFILES = $(GENERATED_ITEMS)
-include $(top_srcdir)/git.mk