summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e1beebac4..a333fe0eb 100644
--- a/configure.in
+++ b/configure.in
@@ -133,6 +133,8 @@ case $gdktarget in
*) AC_MSG_ERROR([Invalid target for GDK: use x11, nanox or linux-fb.]);;
esac
+AC_ARG_ENABLE(shadowfb, [ --disable-shadowfb disable shadowfb support for linux-fb],,enable_shadowfb=yes)
+
if test "x$enable_debug" = "xyes"; then
test "$cflags_set" = set || CFLAGS="$CFLAGS -g"
GTK_DEBUG_FLAGS="-DG_ENABLE_DEBUG"
@@ -146,6 +148,7 @@ fi
AC_DEFINE_UNQUOTED(GTK_COMPILED_WITH_DEBUGGING, "${enable_debug}")
+
# Build time sanity check...
AM_SANITY_CHECK
@@ -591,11 +594,16 @@ if test "x$gdktarget" = "xlinux-fb"; then
FREETYPE_CFLAGS="`$FREETYPE_CONFIG --cflags`"
FREETYPE_LIBS="`$FREETYPE_CONFIG --libs`"
CFLAGS="$CFLAGS $FREETYPE_CFLAGS"
+
+ if test x$enable_shadowfb = xyes ; then
+ AC_DEFINE(ENABLE_SHADOW_FB)
+ fi
AM_CONDITIONAL(USE_LINUX_FB, true)
else
AM_CONDITIONAL(USE_LINUX_FB, false)
fi
+AC_SUBST(ENABLE_SHADOW_FB)
AC_SUBST(FREETYPE_LIBS)
AC_SUBST(FREETYPE_CFLAGS)