summaryrefslogtreecommitdiff
path: root/contrib/gdk-pixbuf-xlib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/gdk-pixbuf-xlib/Makefile.am')
-rw-r--r--contrib/gdk-pixbuf-xlib/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/contrib/gdk-pixbuf-xlib/Makefile.am b/contrib/gdk-pixbuf-xlib/Makefile.am
index dabdb52d0..611a838ad 100644
--- a/contrib/gdk-pixbuf-xlib/Makefile.am
+++ b/contrib/gdk-pixbuf-xlib/Makefile.am
@@ -1,3 +1,7 @@
+if PLATFORM_WIN32
+no_undefined = -no-undefined
+endif
+
lib_LTLIBRARIES=libgdk_pixbuf_xlib-2.0.la
INCLUDES = \
@@ -9,6 +13,7 @@ INCLUDES = \
libgdk_pixbuf_xlib_2_0_la_LDFLAGS = \
-export-dynamic \
+ $(no_undefined) \
-version-info $(LT_VERSION_INFO)
libgdk_pixbuf_xlib_2_0_la_LIBADD = \