summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index e22c31827..c2a121042 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -161,11 +161,11 @@ libgdk_win32_2_0_la_SOURCES = $(common_sources) gdkkeynames.c
libgdk_win32_2_0_la_LIBADD = win32/libgdk-win32.la $(GDK_DEP_LIBS) \
$(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la
libgdk_win32_2_0_la_DEPENDENCIES = win32/libgdk-win32.la win32/rc/gdk-win32-res.o gdk.def
-libgdk_win32_2_0_la_LDFLAGS = -Wl,win32/rc/gdk-win32-res.o -export-symbols gdk.def $(LDADD)
+libgdk_win32_2_0_la_LDFLAGS = -Wl,win32/rc/gdk-win32-res.o -export-symbols $(srcdir)/gdk.def $(LDADD)
if OS_WIN32
install-def-file: gdk.def
- $(INSTALL) gdk.def $(DESTDIR)$(libdir)/gdk-win32-2.0.def
+ $(INSTALL) $(srcdir)/gdk.def $(DESTDIR)$(libdir)/gdk-win32-2.0.def
uninstall-def-file:
-rm $(DESTDIR)$(libdir)/gdk-win32-2.0.def
else
@@ -189,8 +189,10 @@ install-ms-lib:
uninstall-ms-lib:
endif
+# This places the generated .def file in srcdir, since it is expected to be there.
+# (The one from a tarball is)
gdk.def: gdk.symbols
- (echo -e EXPORTS; $(CPP) -P -DALL_FILES -DGDK_WINDOWING_WIN32 -DINCLUDE_VARIABLES - <$(srcdir)/gdk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > gdk.def
+ (echo -e EXPORTS; $(CPP) -P -DALL_FILES -DGDK_WINDOWING_WIN32 -DINCLUDE_VARIABLES - <$(srcdir)/gdk.symbols | sed -e '/^$$/d' -e 's/^/ /' -e 's/G_GNUC_[^ ]*//g') > $(srcdir)/gdk.def
gdkalias.h: gdk.symbols
$(PERL) $(srcdir)/makegdkalias.pl < $(srcdir)/gdk.symbols > gdkalias.h