summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1acc43595..7880577dc 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project('gdk-pixbuf', 'c',
- version: '2.42.3',
+ version: '2.42.5',
license: 'LGPL-2.1-or-later',
default_options: [
'buildtype=debugoptimized',
@@ -94,7 +94,7 @@ if cc.has_function('lrint', dependencies: mathlib_dep)
endif
intl_dep = cc.find_library('intl', required: false)
-if cc.has_function('bind_textdomain_codeset', prefix: '#include <libintl.h>', dependency: intl_dep)
+if cc.has_function('bind_textdomain_codeset', prefix: '#include <libintl.h>', dependencies: intl_dep)
gdk_pixbuf_conf.set('HAVE_BIND_TEXTDOMAIN_CODESET', 1)
endif
@@ -408,6 +408,10 @@ if not meson.is_cross_build()
endif
endif
+if not meson.is_subproject()
+ meson.add_dist_script('build-aux/dist.py')
+endif
+
summary = [
'',
'GDK-Pixbuf @0@'.format(meson.project_version()),