summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index 046e54419..96ac157d0 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -98,3 +98,10 @@ EXTRA_DIST = \
README \
marshalers.list \
$(BUILT_SOURCES)
+
+# if srcdir!=builddir, clean out maintainer-clean files from builddir
+# this allows dist to pass.
+distclean-local:
+ if test $(srcdir) != .; then \
+ rm -f $(MAINTAINERCLEANFILES); \
+ fi