summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* 2.7.3GTK_2_7_3Matthias Clasen2005-07-15172-27235/+29641
|
* Updated Spanish translation.Francisco Javier F. Serrador2005-07-152-79/+99
| | | | | | 2005-07-15 Francisco Javier F. Serrador <serrador@cvs.gnome.org> * es.po: Updated Spanish translation.
* UpdatesMatthias Clasen2005-07-154-3/+47
| | | | | | 2005-07-15 Matthias Clasen <mclasen@redhat.com> * NEWS: Updates
* Don't treat whitespace as words for keynav, pointed out by Owen Taylor.Matthias Clasen2005-07-154-37/+63
| | | | | | | | 2005-07-15 Matthias Clasen <mclasen@redhat.com> * gtk/gtkentry.c (gtk_entry_move_forward_word): (gtk_entry_move_backward_word): Don't treat whitespace as words for keynav, pointed out by Owen Taylor.
* Take the parent folder path instead of the display name, to avoid doingFederico Mena Quintero2005-07-151-69/+54
| | | | | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/gtkfilechooserdefault.c (should_respond_after_confirm_overwrite): Take the parent folder path instead of the display name, to avoid doing duplicated work in gtk_file_chooser_default_should_respond().
* Take the parent folder path instead of the display name, to avoid doingFederico Mena Quintero2005-07-153-0/+21
| | | | | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/gtkfilechooserdefault.c (should_respond_after_confirm_overwrite): Take the parent folder path instead of the display name, to avoid doing duplicated work in gtk_file_chooser_default_should_respond().
* Take the display name of the folder as well so that we can present aFederico Mena Quintero2005-07-154-22/+132
| | | | | | | | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/gtkfilechooserdefault.c (confirm_dialog_should_accept_filename): Take the display name of the folder as well so that we can present a better message. Use a stock cancel button, "_Replace", and GTK_STOCK_SAVE_AS. (gtk_file_chooser_default_should_respond): Pass the file part and folder display name directly to the function above. Oops, only do the confirmation dialog if the file exists.
* Update UpdateKjartan Maraas2005-07-153-1116/+1157
| | | | | | | 2005-07-15 Kjartan Maraas <kmaraas@gnome.org> * nb.po: Update * no.po: Update
* Use header capitalization for the buttons, per the HIG.Federico Mena Quintero2005-07-154-2/+14
| | | | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/gtkfilechooserdefault.c (confirm_dialog_should_accept_filename): Use header capitalization for the buttons, per the HIG.
* Add the new functions.Federico Mena Quintero2005-07-155-6/+13
| | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/gtk.symbols: Add the new functions.
* Add "Since 2.8" to the signal and enum.Federico Mena Quintero2005-07-152-0/+12
| | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/tmpl/gtkfilechooser.sgml: Add "Since 2.8" to the signal and enum.
* Add a test for the confirm-overwrite signal.Federico Mena Quintero2005-07-154-23/+107
| | | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * tests/testfilechooser.c (confirm_overwrite_cb): Add a test for the confirm-overwrite signal.
* Add a "save" example to the typical usage.Federico Mena Quintero2005-07-158-2/+193
| | | | | | | | | | | | | | 2005-07-15 Federico Mena Quintero <federico@ximian.com> * gtk/tmpl/gtkfilechooserdialog.sgml: Add a "save" example to the typical usage. * gtk/gtk-sections.txt: Add GtkFileChooserConfirmation, gtk_file_chooser_set_do_overwrite_confirmation, gtk_file_chooser_get_do_overwrite_confirmation. * gtk/tmpl/gtkfilechooser.sgml: Document the confirmation signal and enumeration; provide an example.
* Add overwrite confirmation for SAVE mode. Fixes bug #152850:Federico Mena Quintero2005-07-1511-13/+407
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | 2005-07-14 Federico Mena Quintero <federico@ximian.com> Add overwrite confirmation for SAVE mode. Fixes bug #152850: * gtk/gtkfilechooser.h: Add prototypes for gtk_file_chooser_set/get_do_overwrite_confirmation(). (GtkFileChooserConfirmation): New enum for the result of the "confirm-overwrite" signal. * gtk/gtkmarshalers.list: Add ENUM:VOID. * gtk/gtkfilechooser.c (gtk_file_chooser_class_init): Add a "do-overwrite-confirmation" boolean property. (gtk_file_chooser_set_do_overwrite_confirmation): Implement. (gtk_file_chooser_get_do_overwrite_confirmation): Implement. (confirm_overwrite_accumulator): New accumulator for the signal. * gtk/gtkfilechooserutils.h (GtkFileChooserProp): Add GTK_FILE_CHOOSER_PROP_DO_OVERWRITE_CONFIRMATION. * gtk/gtkfilechooserutils.c (_gtk_file_chooser_install_properties): Override the do-overwrite-confirmation property. * gtk/gtkfilechooserprivate.h (struct _GtkFileChooserIface): Add a confirm_overwrite signal to the vtable. * gtk/gtkfilechooserdefault.c (gtk_file_chooser_default_set_property): Handle the new property. (gtk_file_chooser_default_get_property): Likewise. (get_selected_file_info_from_file_list): New helper function; code taken from list_selection_changed(). (list_selection_changed): Use get_selected_file_info_from_file_list(). (should_respond_after_confirm_overwrite): New function. (gtk_file_chooser_default_should_respond): Confirm when necessary.
* Add new apiMatthias Clasen2005-07-142-0/+7
|
* Add new exported symbols.Matthias Clasen2005-07-144-0/+15
| | | | | | 2005-07-14 Matthias Clasen <mclasen@redhat.com> * gtk/gtk.symbols: Add new exported symbols.
* Implement getting the MIME type of a file. Look it up in the Registry. BugTor Lillqvist2005-07-144-16/+48
| | | | | | | | 2005-07-14 Tor Lillqvist <tml@novell.com> * gtk/gtkfilesystemwin32.c (filename_get_info): Implement getting the MIME type of a file. Look it up in the Registry. Bug reported by Hans Oesterholt.
* Don't need -luuid on Win32. It was some leftover, and in fact occasionallyTor Lillqvist2005-07-144-1/+28
| | | | | | | | | | | 2005-07-14 Tor Lillqvist <tml@novell.com> * configure.in (GDK_EXTRA_LIBS): Don't need -luuid on Win32. It was some leftover, and in fact occasionally caused issues with libtool as it made its way into the libgdk-win32-2.0.la file and that way into the .la files of all libraries that depend on GDK. (This happened only when building from CVS and not using a full "make install" which would run the sanitize-la.sh script.)
* Don't assert if the xrootwin is invalid. (#309997, Barbie LeVille)Matthias Clasen2005-07-144-15/+57
| | | | | | | | 2005-07-14 Matthias Clasen <mclasen@redhat.com> * gdk/x11/gdkevents-x11.c (set_screen_from_root): Don't assert if the xrootwin is invalid. (#309997, Barbie LeVille) (gdk_event_translate): Ignore events with an invalid root field.
* Set interface age to 0.Matthias Clasen2005-07-145-4/+24
| | | | | | | | | 2005-07-14 Matthias Clasen <mclasen@redhat.com> * configure.in: Set interface age to 0. * gtk/gtkimmodule.h: Move G_BEGIN_DECLS to the right spot, noticed by Akira Tagoh.
* Updated Czech translation.Miloslav Trmac2005-07-144-276/+302
| | | | | | 2005-07-14 Miloslav Trmac <mitr@volny.cz> * cs.po: Updated Czech translation.
* ushe imaIvan Stojmirov2005-07-141-85/+102
|
* new function (fixes #169961, reported by Morten Welinder).Kristian Rietveld2005-07-145-0/+34
| | | | | | | 2005-07-14 Kristian Rietveld <kris@gtk.org> * gtk/gtktreeviewcolumn.[ch] (gtk_tree_view_column_queue_resize): new function (fixes #169961, reported by Morten Welinder).
* new function. (fixes #105252, suggestion from Mikael Hallendal).Kristian Rietveld2005-07-135-0/+65
| | | | | | | 2005-07-14 Kristian Rietveld <kris@gtk.org> * gtk/gtktreeview.[ch] (gtk_tree_view_get_visible_range): new function. (fixes #105252, suggestion from Mikael Hallendal).
* remove unused variable.Manish Singh2005-07-134-18/+29
| | | | | | 2005-07-13 Manish Singh <yosh@gimp.org> * demos/gtk-demo/iconview_edit.c: remove unused variable.
* new function. (#160879, Stefan Kost).Kristian Rietveld2005-07-135-0/+35
| | | | | | | 2005-07-13 Kristian Rietveld <kris@gtk.org> * gtk/gtktreemodel.[ch] (gtk_tree_row_reference_get_model): new function. (#160879, Stefan Kost).
* paint a flat box on the area the treeview got allocated extra verticallyKristian Rietveld2005-07-135-12/+53
| | | | | | | | | | | | 2005-07-13 Kristian Rietveld <kris@gtk.org> * gtk/gtktreeview.c (gtk_tree_view_bin_expose): paint a flat box on the area the treeview got allocated extra vertically (fixes #142063, reported by Brian Bober). * gtk/gtktreeviewcolumn.c (gtk_tree_view_column_cell_process_action): make this function calculate real_cell_area and real_background_area correctly. (fixes #309249, reported by Bernd Demian).
* Fix an unintentional case of width-for-height... (#310133, Luis Villa)Matthias Clasen2005-07-134-1/+16
| | | | | | | 2005-07-13 Matthias Clasen <mclasen@redhat.com> * gtk/gtkcalendar.c (calendar_realize_arrows): Fix an unintentional case of width-for-height... (#310133, Luis Villa)
* let's take the MIN of width and max_width here, not width and max_width !=Kristian Rietveld2005-07-134-1/+19
| | | | | | | | 2005-07-13 Kristian Rietveld <kris@gtk.org> * gtk/gtktreeview.c (gtk_tree_view_new_column_width): let's take the MIN of width and max_width here, not width and max_width != -1. (fixes #144480, reported by Mikael Magnusson).
* Don't keep the caches for unthemed directories in a separate list, insteadMatthias Clasen2005-07-134-32/+31
| | | | | | | | | | 2005-07-13 Matthias Clasen <mclasen@redhat.com> * gtk/gtkicontheme.c (load_themes): Don't keep the caches for unthemed directories in a separate list, instead append them at the end of the dir_mtimes list, so that we can check them for staleness like the other caches. (#310221, Mark McLoughlin)
* Check the cairo versionMatthias Clasen2005-07-134-1/+15
|
* Fix handling of Aiptek and Aiptek-like graphical tablets such as Trust onRobert Ögren2005-07-134-130/+82
| | | | | | | | | | | | | | | | | | 2005-07-13 Robert Ögren <gtk@roboros.com> Fix handling of Aiptek and Aiptek-like graphical tablets such as Trust on Windows. (#167004, thanks to "pnohant" for testing) Code cleanup: Remove the unused and unmaintained code for using a non-system tablet context (USE_SYSCONTEXT ifdef:s), suggested by Tor Lillqvist. * gdk/win32/gdkinput-win32.c (_gdk_input_wintab_init_check): Handle tablet drivers that don't support WTI_DDCTXS/WTI_DSCTXS gracefully. Sligthly reorganize and simplify the code to support this. (_gdk_input_wintab_init_check, _gdk_input_other_event): Remove USE_SYSCONTEXT ifdef:s and the code for the case it was not defined. (gdk_input_window_find_within): Removed.
* Add Copyright/License information.Matthias Clasen2005-07-134-0/+31
| | | | | | 2005-07-13 Matthias Clasen <mclasen@redhat.com> * gdk/win32/bdfcursor.c: Add Copyright/License information.
* when !separator, don't add the focus_line_width to width/height (happensKristian Rietveld2005-07-135-3/+40
| | | | | | | | | | | | 2005-07-13 Kristian Rietveld <kris@gtk.org> * gtk/gtktreeview.c (validate_row): when !separator, don't add the focus_line_width to width/height (happens in _column_cell_get_size), but do add the vertical-separator to height, we weren't taking this into account before. * gtk/gtkentrycompletion.c (_gtk_entry_completion_resize_popup): take vertical-separator into account. (#309137, Ross Burton).
* Add Copyright/License information.Matthias Clasen2005-07-1339-12/+881
|
* Updated Slovak translation.Marcel Telka2005-07-132-19/+22
| | | | | | 2005-07-13 Marcel Telka <marcel@telka.sk> * sk.po: Updated Slovak translation.
* Add a warning about unreffing icon themes. (#310163, Rodney Dawes)Matthias Clasen2005-07-134-2/+20
| | | | | | | | 2005-07-13 Matthias Clasen <mclasen@redhat.com> * gtk/gtkicontheme.c (gtk_icon_theme_get_default) (gtk_icon_theme_get_for_screen): Add a warning about unreffing icon themes. (#310163, Rodney Dawes)
* quit maintaining the iter on every iteration, only get the iter when weKristian Rietveld2005-07-124-32/+37
| | | | | | | | | | | 2005-07-13 Kristian Rietveld <kris@gtk.org> * gtk/gtktreeselection.c (gtk_tree_selection_selected_foreach): quit maintaining the iter on every iteration, only get the iter when we are about to call the foreach_func. Gives us a 10x speedup, since maintaining iters is a lot more expensive than maintaining paths. We lose a bit of sanity checking though. Thanks go to Billy Biggs for pointing this out.
* ushe dosta rabotaIvan Stojmirov2005-07-121-227/+192
|
* Updated Spanish translation.Francisco Javier F. Serrador2005-07-122-551/+561
| | | | | | 2005-07-13 Francisco Javier F. Serrador <serrador@cvs.gnome.org> * es.po: Updated Spanish translation.
* Fix the buildMatthias Clasen2005-07-121-1/+1
|
* Hungarian translation updated.Gabor Kelemen2005-07-124-2006/+1936
| | | | | | 2005-07-12 Gabor Kelemen <kelemeng@gnome.hu> * hu.po: Hungarian translation updated.
* Fix the same confusion here, too.Matthias Clasen2005-07-124-3/+9
| | | | | | 2005-07-12 Matthias Clasen <mclasen@redhat.com> * tests/testcairo.c (draw): Fix the same confusion here, too.
* Fix cairo_content_t <-> cairo_format_t confusion. (#310086, CarlosMatthias Clasen2005-07-124-1/+13
| | | | | | | | 2005-07-12 Matthias Clasen <mclasen@redhat.com> * gdk/gdkgc.c (make_stipple_tile_surface): Fix cairo_content_t <-> cairo_format_t confusion. (#310086, Carlos Garnacho Parro)
* Forgot to commit this one.Tor Lillqvist2005-07-121-2/+0
|
* Follow the Nautilus change and rename "Filesystem" to "File System",Matthias Clasen2005-07-124-1/+22
| | | | | | | | | 2005-07-12 Matthias Clasen <mclasen@redhat.com> * gtk/gtkfilesystemunix.c (gtk_file_system_unix_volume_get_display_name): Follow the Nautilus change and rename "Filesystem" to "File System", string change. (#310047, Vincent Noel)
* Rename this demo.Matthias Clasen2005-07-126-5/+179
| | | | | | | | | 2005-07-12 Matthias Clasen <mclasen@redhat.com> * demos/gtk-demo/iconview.c: Rename this demo. * demos/gtk-demo/iconview_edit.c: Add a demo for icon view editing and drag-and-drop.
* Correct copyright informationMatthias Clasen2005-07-128-8/+8
|
* Accept dashes in demo titles.Matthias Clasen2005-07-124-2/+14
| | | | | | 2005-07-12 Matthias Clasen <mclasen@redhat.com> * demos/gtk-demo/geninclude.pl.in: Accept dashes in demo titles.
* Translation updated by Ivar Smolin.Priit Laes2005-07-122-568/+577
| | | | | | 2005-07-12 Priit Laes <plaes@cvs.gnome.org> * et.po: Translation updated by Ivar Smolin.