summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-01-15 16:49:07 -0500
committerColin Walters <walters@verbum.org>2012-04-30 18:34:45 -0400
commit7764799e356fb482f732e3a248e22d69d5e4d86b (patch)
tree4fbc7e69ae7034851233a7d55dd61893f650e4cd /Makefile.am
parent67d91afb77a162961c1dd86634a6ebe0136ac7a2 (diff)
downloadgdm-7764799e356fb482f732e3a248e22d69d5e4d86b.tar.gz
build: Add --disable-documentation
Documentation is the source of many cyclical build loops. Allow operating system builders to manually cut these cycles initially by disabling documentation for a first pass. https://bugzilla.gnome.org/show_bug.cgi?id=675087
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f522f402..c1808548 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,12 +4,14 @@ SUBDIRS = \
data \
common \
daemon \
- docs \
gui \
utils \
po \
tests \
$(NULL)
+if ENABLE_DOCUMENTATION
+SUBDIRS += docs
+endif
# add these when help gets added back
# omf-install
@@ -27,6 +29,6 @@ DISTCLEANFILES = \
gnome-doc-utils.make \
$(NULL)
-DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper --enable-split-authentication --enable-introspection
+DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper --enable-split-authentication --enable-introspection --enable-documentation
distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'